I hate windows!

On the 2nd day of a 10hr project, about halfway thru the carve I notice the router isn’t moving anymore, turns out my laptop had just shutdown on it’s own. No error message on restart like I’ve seen in the past, I checked the upgrade manager (which was set to not do anything during the day) and it claims the last update was yesterday. Power was on so it didn’t try to shutdown due to power. I have no idea why it just decided to go bye-bye. This is Windows 10. I don’t trust the upgrade manager but couldn’t find where I can turn it off completely which would be my preference. I’ll have to estimate where the last zero point was and then remove items that have already carved. I think it’ll be pretty much OK, but that one item being carved will probably be munged since I doubt I will hit the same zero point exactly. It’s at the bottom left corner of the board so it will be close. It’s part of an inlay project so it will probably be noticeable.

Your laptop may have went to hibernation (you can turn it off by running this from the command prompt -> powercfg.exe /hibernate off)

You can manually turn off automatic download of Windows update as well. Easiest way to do it is to turn on Metered connection in your WiFi connection settings

1 Like

It has never done that before. I carved for a much longer time yesterday and the last few weeks than today. It didn’t go to sleep because the things running were not there… it was a complete new boot. If it wakes up from sleep, it should’ve had everything I had running come back to me. I put my work laptop to sleep every day and stuff is there for me when I wake it up.

I fear the background update where options get changed back to default without telling me, tho.

The metered download thing is a good idea. Will do!

and these are the reasons why I use the Raspberry Pi 3 to control the X-Carve.

Windows 10 now always forces automatic updates. :rage:
You can set it to not updated during a given 12 hour “busy” period every day, but that is it. As far as I know there is no longer any way to turn it off. It has screwed me over at least twice now.

If you are doing a long carve the best way to stop it is to turn of your network connection.

I have also ran into trouble because the power cord to the laptop got knocked loose and it eventual shut down due to low battery.

Make a bump stop with G28. You’ll always go back to the same zero point then if it shuts down on you. I learned that lesson the hard way.

1 Like