I have problem in my z axes

I update my xcarve from 500 to 1000 , I refresh grbl the last version and also upload the file to the ardinuo
now I have depth cut problems and when I check my z axes every things is good
I test v weels is good
tight the belt is in the middle
i try to change the current by adjusting the resistor
I change grbl setting
if I send 0.5 inch they move only 0.25 inches
any sugestions

Post your Grbl $$ output here.

$0=10 (step pulse, usec)

$1=255 (step idle delay, msec)

$2=0 (step port invert mask:xxxxxxxx)

$3=3 (dir port invert mask:xxxxxxxx)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=115 (status report mask:xxxxxxxx)

$11=0.020 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=1 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=3 (homing dir invert mask:xxxxxxxx)

$24=25.000 (homing feed, mm/min)

$25=750.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$30=12000 (rpm max)

$31=0 (rpm min)

$32=0 (laser mode, bool)

$100=40.000 (x, step/mm)

$101=40.000 (y, step/mm)

$102=188.976 (z, step/mm)

$110=8000.000 (x max rate, mm/min)

$111=8000.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=500.000 (x accel, mm/sec^2)

$121=500.000 (y accel, mm/sec^2)

$122=50.000 (z accel, mm/sec^2)

$130=790.000 (x max travel, mm)

$131=790.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

Try changing $102=94.488

I have problem in Z axec and I see that 120 for x axes
And I try this but the same
My cnc before re flashed worked without any problem
I use this update website to re flash grbl

Your grbl settings look fine. $120 doesn’t need to be changed (it’s a typo anyway, he meant $102).

How are you telling the machine to move 0.5 inches?

In pick sender I have the ability to move x,y, z by write 0.5 inch +z or -Z
before re flash it had not any problems

this is my pic sender

I download this grbl to my arduino
i do not know if this for xcontrol or gshield

The same grbl file runs on the Arduino and the X-controller.

Use one of theses files.

1 Like

I use these file and I have the same z axes wrong travel

What was your $102-value before flashing it again?
(Yes, $120 was a typo, original post corrected :wink: )

What happens after you change $102 to = 94.488? (Arduino reset required most likely in order to make the change take effect)

His $102 is correct for the ACME screw. If he has the M8 threaded rod then it would be 320.

His error with the M8 threaded rod would be 188.976/320 = 0.59

0.5 * 0.59 = 0.295 approximatey the error involved.

If his machine is told to move 0.5 inches and it only moves 0.25 inches then depending on the measurement error that could be his problem.

Try setting $102 to 320 and see if that fixes the problem.

I change 102 to 350 and send 0.5 inch to z axes and it was move to 0.56
I go to my work to cut mu profile now it cut the job but at the end I have more moving one more steps so I turn the machine off that means it need to calibrate again
what is the best to make my z axes accurate
This photo to the board under my job
If I set the pass depth is 0.03
The cut pass is 6
I see that 5 pass is what I need so I have one pass is extra
0.03 is now need to reduce from 102
What is the formula?
I set 102 t0 334.450 and cut exactly the depth of the material
I use this tool to measure my x,y,z axes and changes in the program
It is very useful tools and great

1 Like