I Need help Please! Keep Getting This Error

yes exactly, and the weird thing is that if i connect the x-carve through UGS i get the exact same error, and the even weirder thing is that if I go and plug the x-carve to my old laptop it works without and issue in both easel and UGS.

Thanks a lot for responding so quick by the way, I hope you can help me find a solution as I urgently need to get some work done

by the way, on UGS i start getting the errors once I make the connection of computer to x-carve, on easel I get those errors when I go to: Machine/Avanced/Machine Inspector and at the moment I turn on the X-Controller it starts with that thread of errors I show in the picture

The fact that things work normally with the old computer, but not the new one says it’s most likely not an X-carve problem, but a problem with the new computer.

Do you have a different USB device you can use to see if your USB port is working correctly with anything?

1 Like

Are you using the same USB cable you did with the other computer?

I also think that that is the problem, I have a 3D printer that works fine, so my external hard drive, is there a way to check or reset this somehow ? the weird thing is the “Check Door” message I keep getting in both platforms

yes its the same cable

Another thing you could check is to make sure that the COM port set up for the X-carve is set for 115200 baud, 8 data bits, 1 stop bit, no parity, and no flow control.

where can i check this ?

I don’t know, I’m not a Mac person. On Windows it would be device manager.

you mean the USB port where the USB cable that connects computer/x-carve go ? how can i set this up ? Ive got 5 USB ports on my imac

Not surprising both platforms are trying to access the serial port set up for the USB port.

BTW the serial port can only be used by one program at a time. Either UGS or Easel, but not both at the same time.

yes when trying them out is not at the same time, well i found where the USBs are located but i have no way of configuring them

@ErickAcereto
Had to borrow my wife’s Mac for this.
Can you use the built in terminal app to connect?
Open terminal, type ls /Dev/tty.*
When you locate the port that is your X-carve, type
screen /dev/tty.whatever 115200 8n1
You should a Grbl message.
All this does is eliminate some variables with the senders.

wow im super excited that you are helping me :slight_smile:

when i type ls /Dev/tty.* … i get… /Dev/tty.Bluetooth-Incoming-Port … then I type … screen /dev/tty.whatever 115200 8n1… and then i get that there is no such file or directory and the screen terminates

Nevermind… i had the x-controller off… now that it is on… i get the sameeeee error :(… ill copy and past it

iMac-de-Usuario:~ usuario$ ls /Dev/tty.*
/Dev/tty.Bluetooth-Incoming-Port /Dev/tty.usbserial-XCONTROLLER1QJ0
iMac-de-Usuario:~ usuario$ screen /dev/tty.usbserial-XCONTROLLER1QJ0 115200 8n1

Grbl 1.1f [’$’ for help]
error:2
error:1
error:2
error:1

Grbl 1.1f [’$’ for help]
error:2
error:1
error:1
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
error:1
<Idle|MPos:0.000,0.000,0.000|Bf:15,126|FS:0,0|WCO:0.000,-0.300,-10.500>
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
[MSG:Check Door]
Door:0|MPos:0.000,0.000,0.000|Bf:15,0|FS:0,0|WCO:0.000,-0.300,-10.500

Grbl 1.1f [’$’ for help]
[MSG:Check Door]
[MSG:Check Door]
[MSG:Check Door]

Grbl 1.1f [’$’ for help]

Grbl 1.1f [’$’ for help]
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
error:2
error:1
<Idle|MPos:0.000,0.000,0.000|Bf:15,126|FS:0,0|WCO:0.000,-0.300,-10.500>
[MSG:Check Door]
[MSG:Check Door]
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
error:1
error:2
ok
error:2
error:20
ok

Grbl 1.1f [’$’ for help]
[MSG:Check Door]
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
<Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|WCO:0.000,-0.300,-10.500>
[MSG:Check Door]
[MSG:Check Door]

Grbl 1.1f [’$’ for help]
error:1

Grbl 1.1f [’$’ for help]
error:2
error:2
error:2

Grbl 1.1f [’$’ for help]

Grbl 1.1f [’$’ for help]
[MSG:Check Door]
[MSG:Check Door]
[MSG:Check Door]

that is the exact same thing that happens with both easel and UGS

Can you try a different USB port? Then a different cable.
No reason to go through terminal again since results are the same.

Check your front panel buttons on the Xcontroller. Make sure none are accidentally pushed in. A “pause” on the Xcontroller causes a door open state.

But you’ve probably got some garbage on the serial bus. Trying reinstalling the FTDI drivers.

Look at this post and follow his steps:

If it were me, I would re flash the x controller to grbl 1.1f, and then go back through the machine setup from setup 1.

It sounds like something has corrupted the config file in the x controller, leading to the safety door message. This is a setting in the config file for grbl, but is normally commented out before compiling.

X-carve works fine on his other computers. It’s not an X-carve issue.

From message above, we can see that the “Feed Hold” (door open state) is not tripped.

<Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|WCO:0.000,-0.300,-10.500>

Exactly, but if I remember correctly, the easel setup procedure also adjust settings within the driver, does it not?

Performing the setup again would then redo those settings and overwrite any driver corruption.