I'm at my wits end with x-carve disconnecting! please help

I’ve tried everything… or at least what I think is everything. My X-Carve 1000 with X-controller, disconnects in the middle of jobs ALL THE TIME. It will disconnect sometimes when I’m not even cutting… I am using easel. is there a different program, with easy, cheap CAD?

Here is a list of stuff I’ve tried:

-I have tried different different usb cables… numerous.
-connecting X-controller power to different circuits in house to see if it was a power failure issue,
-I’ve tried 3 different computers… 2 laptops, 1 desktop.
-updated drivers
-tried different wifi connections… 2.4g, 5g
-Tried directly connecting internet through Cat5e cable versus using wifi.
-Moved it to my office on a different internet source…
-Contacted Inventables… they sent me a new board for x-controller…


PLEASE help me. Do you guys have any Ideas of what I can do to stop this.

Thanks in advance.

1 Like

Did you try connecting directly to the board with a USB cable, bypassing the USB bulkhead? There’s a known issue with the USB bulkheads.

1 Like

Did you change your computer settings to stop it from going to sleep?

This fixed my issue with disconnections. Inventables sent me a new connector but it had same problem so i just left it connected dirctly to the board,


Try using PICSENDER. It is not web based, so you don’t have to have an Internet connection. Also use a powered USB hub and shielded USB cable.


Agree 100% That fixed this exact issue for me. I’ve left the USB wired directly to the board for the past three months and no problems.


i have not done that… it would requite a different cable… that I don’t have. They did send me a new USB bulkhead and still the issues… I might try getting yet another cable… just the micro usb and see if that does help…

Good to know that the micro usb cable fixed your issue. I will have to try that.

bobjewell. I have definitely done the research on it… there are so many answers. That is why I reached out to try and figured out what ACTUALLY worked.

I just ordered a shielded usb to micro usb to eliminate the bulkhead. I also ordered a powered usb hub. We’ll see how that works. Thanks for the help!

Are you doing anything that may cause this? For a long time I couldn’t even turn off the fluorescent lights in my shop or the wifi would disconnect. Luckily(?) my laptop died and I had to replace it. No problems since; apparently the wifi receiver in the old laptop was weak. Something I didn’t know I had to worry about.

I was having the same issue. I also made cable changes and such but to no avail. It wasn’t until I followed Phil’s suggestion “Larry jtech grbl version 1.0c and easel local 3.2 has been the most stable.” Since then I have run several lengthy carved with no issue.

1 Like

I believe I figured out the issue. It ended up being my x-carve power supply. Once I changed that it has been much better. I still get an occasional disconnect but not near as often as I used to… Thanks for all your help!!! It is much appreciated

1 Like

I have my own controller, rolled DIY - and in my shop I have one 16A circuit available. Vacuum cleaner, spindle, shelf lighting and I can use anything at will. Controller is solid. Yet flipping the switch for the ceiling fluorescent lights kill my USB-connection and the green carve button go blue for like 2s.

So when dealing with situations like these one must be methodical and thorough.

1 Like

One problem I had was the power wire was not plugged in all the way on the XController. It felt tight but a slight movement would cause it to briefly disconnect. It had felt like it was plugged in all the way but not until I put a lot of push on it did it finally snap in completely.