I'm missing something in creating g-code

Newbie here.

I’ve now used Easel to create g-code (.nc) files for two projects.

When I send these to the Sainsmart 3020 Pro, using ‘ugsplatform’, from my laptop, the spindle never rotates - the program just gouges the pine wood that I’m using for experimentation. XYZ movements are correct, just no spindle rotation. I’m using a 30° bit in the spindle.

If I use one of the sample files that came with the Sainsmart machine, the spindle does spin at a high-rate.

There must be a setting that I’m missing when creating the .nc code file.

My tower machine, where I do design work, and my laptop - connected to the CNC, are both running Linux Mint 20.3

Glad to provide .stl and .nc files to anyone for testing.

Thanks for assistance,

In easel go to Machine>Edit machine
Make sure the spindle control is set to “Hardware” and the spindle type set to “other” and the rpm should be 10,000 both in there and in the cut settings.

Thanks, that worked.

I’m having another issue with Easel, but that will wait for another day (tomorrow?) and I need to do further testing so that I can properly explain.

Thanks again,

1 Like

Looking for assistance in Easel, downloaded a design from Etsy, when imported it shows the entire design. When reviewing the detailed view only part of the design is being cut. I think it may be due to only roughing, but I’m not sure how to view the detailed cuts.

Is it possible that you’re design is too large for your smaller bit?

I suggest selecting a V-Bit to see if this fixes the issue.

Vbut selection worked, thanks for your suggestion!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.