I'm still getting drift and feel like I've tried everything

Hey everyone.

I can’t see to carve anything straight. I’m wondering if anyone knows how I can go about debugging this. Here’s the story.

I have cut somethings reasonably well in the past. I had some beginners luck I’ll call it and things cut pretty well. I cut Delrin plastic and some wood carvings a few months ago without any problems. I didn’t use the X-Carve much for a couple of months and now I’ve been back at it getting drift 100% of the time.

I thought first it was likely the belts and v-wheels. I did have a problem with the X-axis belt and I zip tied it per suggestion of another drift thread on this forum. Both the x and y axis belts now pluck like guitar strings and have all week.

I did have a few v-wheels also a tad lose so I tightened them up, but not too tight. According to the setup they should be just past able to be spun with a figger rubbing on them and that’s where they are at the moment.

Set screws:
I’ve made sure the set screws on the shafts of the motors connecting the pulley are nice and tight. They don’t ever seem to have had a problem slipping but I double checked them anyway.

I then read about the amount of current that the motors are getting. I adjusted the pots on the gshield and played around with them a good deal. I am getting fairly fluid movement across the x and y axis as far as I can see.

Spindle interference:
I ran a marker test both with the spindle on and the spindle off. In all tests they seemed to be just fine accept for one where it drifted. I can’t recreate it but it was with the spindle off. I think this means my spindle is fine and not giving me interference.

I’ve double checked the wires for tight connections and everything seems fine.

Cutting speeds and feed rates.
I changed around my cutting speeds. I’m doing Polycarbonate at 40 in/min and 0.01 depth with a 1/8" bit. All of this tells me that it’s probably cutting speeds and feed rates that must be the problem since it’s always possible for the machine to snag on the project and lose a step. I took apart my automatic vacuum and have been clearing chips by hand to make sure they are all gone as I cut.

What am I missing? Any anyone help me debug this?

1 Like

As a test of last resort, try this.

Move the spindle all the way to the front left corner (home).

** Be sure there is no bit in the spindle and the spindle is not spinning ***

Set the jog control to move 10 inches to the right.

When you click the button to begin the jog to the right use your had to apply a left pushing force. The spindle should strongly resist your hand force and continue moving to the left. Repeat this a few times till you get a good feel for how strong the spindle movement is. If you are “easily” able to stop the movement of the spindle then something is slipping. Either the belt is slipping on the pulley or the motors are not getting enough voltage to power them properly.

If the left/right movement is fine, repeat the test by jogging the spindle backward 10 inches,

What environment was the machine stored in?

Could it be that the rubber of the belts has deteriorated?

If you’re swapping them out, might as well go for 9mm wide belts and matching pulleys and idlers (I got mine from SDP/SI).

I have the standard X-Carve belts with NEMA-17 motors and the quiet spindle. Basically the standard setup and it’s 30cm x 30cm, btw. It’s being stored in my living room, actually. So I think the environment is pretty comfy for it. The belts don’t seem worn and weak and they are holding their tension pretty well.

I tried this yesterday. There was, in fact, an issue with it being too easy to stop the movement of the spindle. I tightened up the set screws really tight and double checked all of the vwheels, adjusting two. It is now really really hard for me to resist the movement of the spindle with my hands. The whole machine moves under it if I hold it and if I hold the spindle and the machine with moderate force it moves past me.

However, I just made a new carving and it’s still way off. I get consistent drift up and to the right every single time.

What am I doing wrong?

So it looks like you found one problem that would have prevented it from carving correctly! Good job.

I assume you checked both the X and Y axis the same way and now both of them move with force if you apply pressure against them.

If that is the case and you are still missing steps, my money would be on improperly set voltage potentiometers.

There are several really good video instructions on this forum showing exactly how to set the voltages correctly.

If you adjust the voltages and still have the same problem, you may need to grind a flat spot on your motor shafts for one of the pulley set screws to tighten against. This will make sure the pulley is not slipping on the shaft.

I just followed this video pretty thoroughly:

Here’s my data:

Dial position refers to the little hash marks on the potentiometer dial. I
start counting at zero.

Max means the maximum dial postion where I was not
getting thermal overload.

Min means the minimum dial position where I was not
getting undercurrent.

X axis:
max: 6.5 and 2.2v
min: 2 and 0.4v
mid: 4.25 and 1.318v

Y axis:
max: 7 and 2.439v
min: 4 and 1.111v
mid: 5.5 and 1.858v

I just did another carving of a rectangular part and again I go drift up and to the right. I ordered some knurled set screws from McMaster-Carr for better grip. Part #91313A119

It seems like my belts and plucking like guitar strings, my potentiometers are as finely tuned as that video tuned hit own. The set screws are pretty darn tight I think.

I just can’t figure out what could possibly be wrong. Does anyone have any other ideas?


Get a sharpie and draw a line across the pulley so the line on the shaft lines up with the line on the pulley. After a test cut check to be sure the pulley has not slipped.

You can also reduce the depth of cut until you no longer have a problem.

That’s a good test, I’ll run that one as soon as I get a chance, thanks a bunch.

Loosing steps in one direction only usually means that belt tension isn’t quite taut enough for that axis (or on the Y-axis, that it’s uneven and one belt isn’t quite taut enough).

I’ve just realized that one of my pulleys is stripped on the inside. I recently bought new set screws with knurled tips and some Loctite 242 to replace all of my set screws. One of my y-coordinate pulleys has a stripped female thread for the set screw and it’s not actually getting very tight. I need to get a replacement. There are a bunch of pulleys in the Inventables store. Does anyone know which ones I should get? I have NEMA17 motors on a 30cm x 30cm machine with the original belts. NEMA 17’s have a 5mm bore size. What about number of teeth or plastic vs. aluminum?

Yep looks like the right one. I’ve ordered a new pulley. Hopefully that fixes my drift issue.

This still didn’t fix my issue, sadly. I’m starting to think that it might be electromagnetic interference with the spindle. I don’t have to push start my spindle and it seems healthy, so maybe that’s not correct. But I have noticed that when I turn the spindle on right when the machine is about to carve but before I actually click “start carving” the lights on the X and Y GShield indicators occasionally blink and I hear the stepper motor sounds. I can’t actually detect any movement on the motors though, even when feeling the axels.

I think a decent test would be to run power to the spindle with a totally new pair of wires and run it to the spindle without getting anywhere near the X,Y,Z wires. Does this sound like a good test?

I’m also wondering why Inventables decided to ditch the spindle I have in favor of just the Dwalt 611. Are there persistent problems with it? Should I be aware of anything having one of these deprecated options?

Yes the original 300 watt quiet spindle had several quality control issues. One of the problems was that it produced a lot of electrical interference. Another issue was the lower bearing failing pretty quickly.

So yes that spindle may be interfering with the motors.

I just got my new Dewalt 611 router and everything is fixed. It was electromagnetic interference all along. Inventables was great about the return policy. They reimbursed me for the old spindle and sent me the new one without shipping charge. The customer service was great. I do wish they’ve been more proactive though about letting everyone with my spindle know that it was fault. Debugging that cost me a few months of carving. But all together, pretty great customer service.

I don’t know how to mark this issue as resolved but it is.

Hi Phil - Could you post a picture showing how you ground the shields? Thanks!