Inventables Community Forum

Inch instead of mm in Machine Inspector

I work almost exclusively in mm and until today the Machine Inspector in Easel always showed the machine position and work position in mm. Today it’s showing it in inches even though when I use G30 it moves it to the right postion. When I use the jog buttons they move the correct number of mm. Has anyone else noticed this? Although it moves the correct distance it’s just a bit disconcerting to see it shown this way. Is there some way to change the Machine Inspector’s indications back to mm?

Thank you, Phil. How did I know that you would have the answer?? I will check that out tomorrow. Thanks again! Your help is much appreciated by all of us!
…Gord

2 Likes

Correct, as usual, Phil. I don’t know what could have made the change to $13 but I changed it back to $13=0 and it’s working just as before. Thanks again!
…Gord

1 Like

If Easel is the only software used, then I think it is an Easel issue.

$13 is an grbl setting, but the fact that $13 got changed is most likely something going on in Easel.

Either a setting got changed whereby Easel decided to change to mm, or a bug somewhere caused the change.

If software other than Easel is in the mix, then your mileage will vary (quite a bit).

Would be my guess.

One problem with Easel is that it is constantly changing. Since it is web based and they don’t provide release notices things change in what appears to be a random order without any user notification. The more you change software the more likely you are to introduce regressive type problems.

2 Likes

Can someone explain in newbie terms how to check my x and y in Machine inspector, when jogging my x or y it moves about 4 inches instead of 1…thanks.

What are your $100-102 values in GRBL?
What kind of controller do you use?

Since this seem to be a scaling issue its most likely a mismatch between microstep settings of the stepper driver vs step/mm value in GRBL.

$100=40.000, $101=40.000, $102=188.976, I have the firmware version. Grbl 1.1g and easel driver version 0.3.20, also, when you first open the Machine Inspector the numbers for the work area, what should they be?

I have the X controller…

Do your dip switches match these?


While you’re checking, switch the #4 switches to the off position. The other three should match for each axis.
X & Y = On-Off-On-Off
Z = Off-On-Off-Off

Yes they do I’ve checked them twice…ok thanks.

Something is not right. I hate to ask, but can you check again?
You’re sure when you jog 1", the machine actually move 4"? Is that XY and Z?

Just XY. I finally got it to start carving but it was WAY oversized from what I had it designed…

And Dip switches are good?
Can you carve a 1" square and measure?

I will try when I get off work…

There are three factors playing their part in travel, assuming a std 0.8deg/step stepper motor and there is no scale issues in software:

  • IPT (inch of travel pr stepper revolution)
  • Step/mm parameter in GRBL
  • Microstep setting (stepper driver, red switch block)

IPT is known as this is a stock Xcarve correct?
The step/mm value IIRC seem to be default
That leave microstep settings, which you have looked over AFAIK.

If no obvious changes are noted then the simplest fix will be to change your step/mm values for X/Y.
But if current value of 40 give you 4:1 travel reducing step/mm to 10 will give you better result, but 10 is a low number and dont offer you great resolution - so there is an issue somewhere.

Have you re-calibrated? Have you watched this video:

As @HaldorLonningdal and I are suggesting, this isn’t the best way to solve this particular case. The default XY steps/mm for the X-carve is 40. If @DeweyMckee was traveling 1.05" on a one inch jog, then calibration for belt stretch would be the answer.

No, im working will do when I get home…

Thank you guys for responding, we did do a calibration and are good to go, made our first complete carve tonight…