Incomplete carves Windows 10

Hello forum folks,

I’ve been playing around with my X Carve 1000 and Easel for a few weeks now with no major issues up until today. My previous carves were with a Macbook Pro (early 2011) and I’ve had no software/hardware issues. Well, my logic board seems to be taking a dive, so I attempted to carve this evening with my work computer which is a 2016 Microsoft Surface Book running Windows 10. I’ve attempted three carves using two different Easel files on my Surface and each of these carves prompt the, “How’d it turn out?” message somewhere between the 5-15% completion point. In all three cases, the machine continues to carve for another ~5 seconds then the spindle stops in its last position - X,Y, and Z.

I’ve checked connections to the machine along with my Wifi connection and all seem good. Also, I’ve since successfully completed the failed carves using my wife’s Macbook Air without previously setting-up or using her machine to carve.

This seems like a driver issue to me and it’s worth noting that I downloaded the driver a few minutes before my first attempt. I also restarted the computer between each failed attempt. I have not tried the gcode route yet and was hoping that I don’t need to. Maybe that should be my next route?

Any help you may provide is so appreciated!

Thank you in advance, Dan

PS. sorry if this is answered somewhere else in the forum. I did not see the issues that I am experiencing in previous posts, but I’ll gladly remove this if someone can point me to an existing solution. Thanks again!

I would try to remove your easel local and install easel local 3.2 which can be found under help-downloads within easel. I lot of people have had problems like this with easel local 3.3.

1 Like

Thanks Kenneth, I’ll give this a try later today. Thanks for your help!

Hi, @DanCancilla - It would also help if you could please send our Inventables CS team an error report for what you’re experiencing.

The best information would come from an error report after you get the “Did everything turn out alright?” dialogue that pops up. You can click “No” and then “Get help from Inventables” to send the error report to us. Describe what happened and upload any accompanying photos of incomplete carve to the form, then send it our way.

You can do this by going to Help > Troubleshooting > Get help from Inventables. This will tell us a little about your machine. It would also help to know about your computer (operating system, web browser, etc.).

We’ve had some Windows connection problems lately, so the error report is the best way for our developers to take a look at the specifics of your machine to see what might be going on. Sorry for the troubles!

Thanks @mstych for your help.

I found out that the issue appears to be with the connection between my computer and the machine. I did as @KennethConnell suggested - uninstalled the local Easel 3.3 driver and replaced it with the 3.2 driver - and I still experienced the same problem. I did finally successfully complete a few carves by physically holding the USB cable into my computer’s port for the duration of the carve, which is super frustrating but is a work around. I’m at a loss as there is no indication that the USB connection is lost (ie. no audible alert from windows, no color change on the “carve” button in Easel). Also, it seems strange that if it were a loose USB connection, which I’ve not experienced with other USB peripherals on this particular computer, that I should receive some type of error message from Easel rather than the “How’d it turn out?” message.

I’ll be sure to submit an error report next time this happens. Thanks again for your help!

1 Like

Thanks for letting us know!

It may be worth noting that we’ve had some trouble with the USB bulkhead cables inside the X-Controller. This may be the result of a bad bulkhead cable inside the controller, hence an unreliable connection. An error report would help us troubleshoot this as well.

We’ll help you get it solved!

is the computer powering down the USB ports to save power?
mine ALL did that until i turned the feature off

Hi Christopher, That’s a possibility. I’ve unchecked the “Stop devices when my screen is off…” option. Is this what you’re refering to? I did not see another option for turning off power to the USBs.

Thanks for the suggestion. I am still trying to find a solution.



You need to disable the Power Managements for the USB ports in the Device Manager also.


^^ what he said