Inkscape grey scale to Easel Cut Depth and Bit Size issues

I made a file on Inkscape and calculated the grey scale that fit the appropriate depth I wanted then imported the SVG into Easel and my depths didn’t work. I’ve read on many forum posts that is how you can create various depths and slopes so it seems like it should have worked but it didn’t. The first time I imported the SVG a couple of the depths worked but I tried redoing it and now they all import as full cuts and I have to select each one and manually adjust them. That’s not a huge issue since there are only about 45 objects and only 3 different depths of cut but if I was doing something more advanced that had a lot of shades of grey to it then it would be a pain to have to reformat them all. I’ve looked through the forum but can’t find an answer to fix this issue.

Also, on the same project it is saying the bit is too large. I set it to 1/32 and it still says that. This is probably because there are some tight angles and small space. I think I read you can ignore that and it will cut what it can cut, but the problem is it won’t show the red marks to see where it can’t cut so I know if it’s an acceptable loss or if I really need to make adjustments. It keeps telling me there is too much detail that will take too long to load and won’t show. It says to view a detailed version to click Show Toolpath, but that’s a mess and I can’t see through it to be able to see what’s going on, even when I hide the material. So is there a way to force it to load, even if it takes a while?

Also, side question, is there a good/easy way to get rid of the Toolpaths once you show them? I’ve used CTRL+Z but that also undoes the last thing I did before showing toolpaths.

Would you mind sharing the SVG that you are trying to import?

I have problems with depths, I put z on zero but when doing cutting it done 10 percent from depth

Here is the SVG. Based on the color formula for grey scale when imported into Easel using 3/4 material, the dark grey should be roughly 3/8 inch, the light grey 1/8 inch, and the white 0 inches. But as I said, the whole thing is importing as all black making it a through cut.

Ok, you have some extra vectors in there that you probably don’t want and you also have a stroke on some of them that is a greenish dotted line. I cleaned it up a bit… try this one:

This will need to be a decently big sign in order to get the lettering right.

Thanks, it worked! I appreciate it, can you give me more info on how you did it properly? That is my issue, I want to be able to make this work on my own without having to have someone fix it. I did see the stroke color thing. But I am really new to this so I’m not sure what you mean by extra vectors and how do I get rid of them? And did just getting rid of the stroke and the extra vectors fix it? Or is there more to it? This sign wasn’t so bad needing to have the grey scale but in the future I want to do more greys, probably even some ramp style items so that’s when it will be necessary to have Inkscape do it, not try to manually do it in Easel.

And the sign is 24 inches long, I’ve practiced in insulation foam and it seems to turn out alright, although the foam is more forgiving than wood…

1 Like

Glad it helped.

I just selected everything that had that greenish outline and hit delete. Then I re-saved it as an SVG and it imported fine. Give it a try with your old file and see how it goes.

Still can’t get it to work. I selected everything, went to the Stroke paint options and turned stroke off which I believe should get rid of the green outlines you mentioned. I’ve tried messing with every setting to make mine match the one you sent back to me and every time I change something on mine or yours and I import them into Easel thinking it has the be the solution mine still imports as all black, and yours still imports with the different grey levels.

I don’t understand why I can’t get this to work. I really want to do some more complex shading to import cut depth into Easel but I can’t even get this simple one to work on Inkscape.

Hmmm… that is odd. Might be something in the settings for InkScape. What you are wanting to do has been done and should be entirely possible. I am pretty good at working out issues when it comes to Illustrator, but InkScape is more foreign to me. With that said, I might differ to @TonyNo or @SeanKeplinger or the like and see if they have any input into what settings might have shifted to cause this issue that you are having.

I imported the original SVG file into Easel and everything looks OK, that is the colors imported fine. The cut depths don’t align with what you have listed up top.

What I did is use the “default” grayscale colors in Inkscape to make a “cut depth color scale”. I made a bunch of boxes, used all of the “percent” color tones in Inkscape and then imported them into Easel. You can then see how deep each one will be.

1 Like

Here’s a picture of the depth gauge – I plan on making a nicer one but this works OK for now.


I really need to make something like that and keep it next to the computer I do my design work on. One of my earlier lamp projects (for a laser cutter, but same idea) ended up being huge b/c I never took the time to inspect it at 100% zoom and I wasn’t paying attention to the measurements. So always a good idea to have something physical nearby to keep yourself grounded :smile:

1 Like

@SeanKeplinger @sketch42

When I read that I had a thought so I tested it. Instead of importing my original SVG that is saved on my computer I downloaded the one I uploaded that you said you used and it worked. I REALLY don’t understand why, it’s the same exact file, all I did different was upload it to this forum then download it and somehow it works on Easel? This is extremely frustrating. What would change the result from my file just by uploading it to Easel? It’s not feasible for me to upload every file to the forum then redownload them just to get them to work. I don’t want to make junk posts just to get functionality. There has to be another way.

As for this, it worked correctly for me this time after downloading my file and then importing it. What material thickness did you have? I had mine set at 0.75 inches.

Perhaps the original file was replaced on the forum when @sketch42 uploaded the new one? I’m not sure what the cut depth was set to. I’ll download it again and check.

Hi @JonathanYarum

Would you mind trying a new file? just a few simple squares in Inkscape and saved as an SVG? I am curious as to why this happened and if it is something that is just a one off or not.

Also out of curiosity… are you using Inkscape on a Windows machine or a Mac?

Oh yeah… BTW… if you just move an object in the work area and move it back, that will get rid of the tool paths… I usually just click an item and hit right arrow and left arrow and the tollbooths go away because there has been a change to the set of vectors. Hope that makes sense.

@sketch42 I’ve attached the test of some rectangles with different grey levels. There should be 4, one at 0% (white), one at 100% (black), and a couple midlevel greys. Again same issue, in Easel it appears all black. As soon as I upload this post I’m going to try to redownload it to see if it works like the other one did. EDIT: I downloaded it and it did work in Easel. So for some reason Easel isn’t liking my Inkscape files until I post them and download them…

I’m using Inkscape on WIndows.

And thanks for the tool path tip, I don’t know why I didn’t think of that, I’ve seen it happen but for some reason when I needed to make the tool paths disappear I forgot that making a change would do it. That was just a dumb moment on my part. Thanks.

EDIT 2: I think I got it. I went to Save As and instead of using the default on Inkscape (which is Inkscape .svg) I tried “Plain .svg” and that didn’t work so then I tried “Optimized .svg” and didn’t change any of the optimization settings, just hit ok on the pop up window then imported it into Easel and my cut levels showed up properly! That probably explains why uploading it to the forum then redownloading it works, the upload probably changes the file a little to be similar to the optimized version. Doesn’t quite make sense that a regular Inkscape .svg doesn’t work but I do have a solution.