Inkscape SVG file won't open

TOTAL newbie here. (Just a few weeks working with a CNC Shapeoko 3) I have been experimenting with Inkscape and Makercam. Trying Easel for first time. I cannot get my Inkscape SVG file to open in Easel. The SVG file does have custom fonts. I put everything “Object to Path”. And as another thread suggested I went back and “Ungrouped” everything, then selected all and did Object to Path again and saved. It will open my graphics only SVG file but when I try just my “words only” files, then get “FAILED IMPORTING SVG”. Any suggestions???

Did you create the file in inkscape?
One trick is to copy everything and paste it into a new. empty inkscape file. Be sure to save as inkscape SVG.
This gives it new header info. which can clear up a lot of problems.

If you can upload a copy of your file I can take a look at it.

TY for the reply Aaron. Yes it was done in Inkscapes. I will try to upload file and try your suggestion.

Not sure the upload worked???


Just tried to copy and make a new document. Still doesn’t work. How do I upload the file for you to see??

There should be a “upload” button in the tool bar of the forum post text box look for the upward pointing arrow icon.

Click on “Reply”, then look for this button here:

PJTX - It only allows (jpg, jpeg, png, gif) files and my Inkscape file is a SVG. Would it be any hep to save it in a different format (don’t know if that is possible) and upload it???

test pattern.tap (30.2 KB)

I think it allows whatever, the text just says jpg, etc.

Try opening your SVG in MakerCam (, then save it. I’ve noticed that while my Inkscape and SketchUp SVG’s won’t open in Easel, they will after going through MakerCam. Don’t know why, but it works.

1 Like

Even though it says that, I have been able to upload SVG files (which is a image format after all :wink: )
Is it blocking you from doing so?
Could there be some kind of limit on the forums for new users?

Aaron, actually on my second post above, it did upload but it is TINY (about the size of the font here.) I clicked on it and opened in another tab and it showed the SVG file.

Weird I can see it, wow it is tiny and to me it is a PNG file? Not SVG

Hmm inkscape sets it units to pixels by default. That may be the problem. Maybe Easel is detecting it as too “small” of an object to import?
Try going into Document properties and changing the both the default units and document units to mm or inches and see if that makes a difference.

I have checked the original. It is in inches (11.25"x15.25") and it is an SVG file. ??? I can get it to open in a new window and it shows a SVG extension.

Thanks for the suggestion Robert, it worked doing this!!!

1 Like