Install Easel Driver ENDLESS LOOP

Haven’t used my x-carve in a couple weeks. I have been using it on a laptop but decided to use an old Nuc for it so set that up, installed the drivers, and logged into Easel. Whenever I try to setup the machine is just asks me to install the Easel driver… rebooted, uninstalled/reinstalled, tried a different browser, bla bla, noting. Tried changing the com port (tried 1-10 to with no luck). I then tried the original laptop that is was working but now it won’t even connect.

So either my x-controller is FUBARed, or Easel is.

Any advice?

OK, working now…

I walked away from it for a bit, watched some Netflix and then started looking in the forum again for similar issues. I found a suggestion from a few months back to add and entry in the system’s host file for to have resolve to I also saw a suggestion to try Firefox, so along with adding the entry in the host file, I tried Firefox and it let me go through the setup process.

I then closed Firefox, and tried to run the setup in Chrome and it worked; at least it let me go through setting up the machine. It did get stuck during the homing calibration (homing ran OK but the screen just sat there at the “Press Stop” screen), so I rebooted the system and ran the setup again and all went well.

So, I guess it was either that Easel was having issues, or the host file entry fixed it. I suppose I could revert the host file and see if it still works, but I’m inclined to just leave it.

If you have any, I welcome any thoughts on the issue.