Installing Easel Local - does not allow 'Set up your machine'

Hi all,
I am having trouble installing Easel local on my 2.4Ghz Intel Core 2 Duo iMac running Snow Leopard v10.6.8. The Easel Local install package runs through the install process, but when I go to ‘Set up my machine’ in Easel in Chrome, it pushes me to the download and install Easel Local page. So, either the link is malfunctioning, or the install package is not truly installing the software.
I have Easel running just fine on another iMac of mine, but was hoping to get it installed on this one as well. Any help would be appreciated.

hi @pike_lake

So you already have Easel local installed on your other iMac… Does it happen to have Snow Leopard on it too?

I am not sure, but your issue might be that you are running Snow Leopard, is there a chance that you might update the Core 2 Duo iMac to the latest OS? (Yosemite is free)

1 Like

@sketch42 Thanks for this! Yes, I was able to install Yosemite. Admittedly, I was a little hesitant to install on an older iMac as I didn’t want to bog it down, but it worked and I will only be using this iMac for the X-Carve so I did it, and, Easel Local immediately worked.
Thanks for the push :smile:

Awesome! Glad I could help.

I actually noticed some improvement when upgrading to Yosemite, but it was on a newer machine.

Happy carving.