Is Easel becoming increasingly unstable?

Hi everyone -

Wondering if you folks are experiencing some “glitches” in Easel lately. I’m having to shut down are restart after a few minutes of carving after my GUI of the design disappears.

Chrome/Macbook Pro/X-Carve/Portland Micro Beer

Am I alone here?

So I’m off Chilipeppr guys. Good luck with Easel, awesome and so simple. Love my X-CARVE BTW!!!


No issues here. I’d reboot and find a different beer.

1 Like

Any chance you post screenshots of what that looks like?

Here is pic of my dilemma. I “homed” and yet the design has gone missing. I’ve come to refer to it as the Sasquatch effect!


Same thing for me, Chrome on a macbook pro.

Usually after I finish ‘printing’/carving

same here i had to start using firefox stuff kept disappearing in chrome

Never occurred to me that it would be Chrome. Must be the issue because I just recently switched over from Safari.

Safari beat out Chrome? What’s the world coming too?

Thanks for the screenshot. We’ve added this as a high priority bug and are looking into it. Can you tell me any more information about what was going on when this happened? You clicked “carve”, then clicked “home” and then exited the walkthrough? Or you started the carve?

The design disappears after its finished carving. About the same time the “how did it turn out?” window pops up. Must be a JAVA thing? Just thinking…

Thanks Paul. You rock!

Here’s a pic of my recent dual carve. Obviously something is wrong in easel.I posted this in its own topic, but havent’ heard much from anyone about what’s wrong or how to fix it.

For me I would lets say make a circle any depth does not matter same end result as soon as i click off of it gone still there but can not see it. if i made adjustments to it I could see it till i click off of it. chrome only worked fine in firefox. Same result on 4 computers. same result different os’s linux, win 7, and win 10

Other than the fact he seems to have set material larger than the 500mm X-Carve bed I don’t see a problem.

1 Like

Look at the e, the p and the two t’s. Problems with each one. The e carved all funny and the others each missed spots with the detail bit.

Hi folks,

Regarding the disappearing canvas issue, we are currently looking into it.

Unfortunately, we haven’t yet had success reproducing it. In researching it, however, we have that there is a known bug in Chrome that appears to manifest itself in the manner that you’ve described.

Specifically, if you resize the drawing area, it may restore the design. If that does not work, we’d love to know!
Also, if you’ve seen this behavior on any browser other than Chrome, could you let us know?

Thanks for your description of this problem!


Chrome, late 2013 Macbook Pro - Most recent carve was just last night (two 38 min runs). No issues last night or Monday night.