Is the homing fail only solved by replacing the cable?

A few things don’t let me rest, with the original firmware (with which the X-Controller arrived), the 0.3.21 Easel driver and the potentiometers in their original state (12 o’clock), everything was fine with the machine , there were inaccuracies during milling, but it fits.

After the driver update (0.4.0), the last rapid movement did not raise the machine to the set original safety height, so it plowed through the material while returning to the starting point.

Corresponding with Inventables, we found that the Z axis does not slip and it doesn’t matter what original safety height I set, it doesn’t raise it high enough either.

I set the potentiometers to 2 o’clock and re-flashed Grbl, as requested by Invetables. As a result, when I want to call the machine home, the Z axis runs for a while and then stops before reaching the limit switch (loud noise from the engine). In the machine inspector, if I manually press the limit switches, I get a green feedback, while the engine hums, it indicates that the switch is not pressed.

I checked the Grbl settings, it was set to $132=100, meanwhile the error in the machine inspector indicated that the Z axis is almost at 150 mm (while in reality it is not), if I changed the $132 value to a higher value , then it’s still a loud noise, but in the machine inspector it showed the maximum Z value again. When I changed $27=1,000 to 5, the situation only got worse.

These are my settings:
$0=10
$1=255
$2=0
$3=4
$4=0
$5=0
$6=0
$10=115
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23 = 3
$24=25,000
$25=750,000
$26=250
$27=1,000
$30=1
$31=0
$32=0
$100=40,000
$101=40,000
$102=188,976
$110=8000,000
$111=8000,000
$112=2000,000
$120=500,000
$121=500,000
$122=50,000
$130=750,000
$131=750,000
$132=100,000

Does anyone have any ideas before I change the wires?

These are the Grbl settings to use: X-Carve default GRBL Settings $$ Values – His N Hers Handcrafted
** I see your $112 is not the default, I also see the settings for your X,Y,Z calibration are for the Pre Nov-2021 model, so if you’ve got the upgraded Z axis and/OR the upgraded X,Y steppers an 9mm belts then you’ll want to correct those settings as well…

Have you done this modification to the Z limit switch? (especially if you’ve got the new Z axis this is a known issue on Every new machine)

Hi, I have the Pre Nov-2021 model, I haven’t upgraded the Z axis. I will try the settings you sent. Which firmware do you recommend and which Easel Driver? Are these main control board settings good?
main control board

1 Like

I don’t think you’ve got much of a choice with the Easel Driver, they said the older drivers will no work going forward…

As for grbl I’ve got a few machines (non are X-Carves) and they have 1.1F, G and H depending on the age of the machines. I’ve not bothered updating grbl if it works fine, there’s not really much to gain by updating. H supports Dual Y limit switches to drive each stepper independently for self-squaring but I don’t use that anyway…

As to the board switch and potentiometer settings. Well, the steppers can use up to 2.4Amps I believe… and the potentiometers in the photo are aimed right at the setting for 2.4A…
Here’s the X-Controller Assembly guide which shows more photos of the stock settings and the silk screen legend of the settings…

HOWEVER I do suggest setting the #4 dip switches to OFF in order to have more Torque for holding the gantry in place during IDLE that way it doesn’t move during bit swaps, as shown here: How to fix X-Carve Lock Motors Fault For Stress Free Bit Changes - YouTube

Thanks for your answers, I’ll go into my workshop and test the settings.

$32=0? This line is missing from the configuration you sent.

1 Like

I made the settings you sent, but when I want to add a new machine to the easel, I can’t move any of the axes and it doesn’t respond to the limit switches.

Oops. Yes $32=0 is spindle (or router mode for CNC carving)
And $32=1 would be for when using a Laser Module

You can send the command $H in the machine inspector page and view the limit switches during the homing cycle.

It worked, my machine is finally working properly.
I re-flashed to Grbl 1.1g, then used the settings you linked, but then when I added the new machine to Easel I couldn’t move it. This was because the soft limit was on, I turned it off and everything is fine now, I hope it doesn’t happen again and I don’t have to change cables.
These settings worked for me.

Pre Nov-2021 model, 1000X1000:


Thank you very much for your help! :slight_smile:

1 Like