Issue when starting a job, after homing

Hello all.

I am using an X-Controller and a 1000,1000mm machine.

My homing cycle works great. At least that’s what I think. After pressing home the machine goes home and the console returns an ok without errors.

My machine values read at: -789, -789, -1 while at home. (is the -1 correct?)

Before starting a job, I go to the zero in the stock and set my work zero values. This is done after homing.

Then when I start a job, the machine moves to the correct start position (not work zero but where the first carve will be done) and the Z axis goes up… and up beyond the homing position!!! it cracks for a bit and then starts the carve…

But of course the work zero values for Z are off. Way off.

Any ideas what I am doing wrong or what is wrongly configured?

Home first, then set work zero, then start. What is your “safe z setting”

Where is that setting? GRBL?

I am also checking to see if I have the latest F360 post processor… If I home first and then set zero, it will drag the tool… before lifting.

Do you have soft limits on?

The setting is in easel or ugs.

Safe Z is a setting in your CAM and is implemented as part of your Gcode file. There’s a few other things it could be called.

Can’t seem to find it in CNCJS… Looking!