Issue with Y1

I am pretty sure this was working before, but I moved and didn’t get a chance to take a look at XCarve for a few months.

My Y1 axis is not moving, and I am not sure how to trouble shoot. Tonight I am thinking of switching Y1/Y2 to see if it my xcontroller.

I upgraded the steppers to 260, but im pretty sure they worked before.

Also I tried upping current, but that didn’t help, so tonight im gonna bounce it back to original.

Im not sure if its a wiring issue for the stepper or what.


Do the other motors work? If so connect Y1 to any of the operating stepper drivers and test function there.

1 Like

YEah, im gonna try that tonight. All 3 others work fine

Ok, seems to be a bad stepper, I swapped Y1/Y2 on XController and it worked the same (Same stepper working, same one not).

I undid the wiring and redid it, same result.

Ordered a new stepper :frowning:

I had similar problems when I first started using our second machine. Turned out that I had a bad connector. I pulled all of the pins and checked the wiring, found one that was a bit dodgy. Fixed it with a quick dab of solder. So, yeah, you might have a bad stepper, but give the connectors a once over.

1 Like

It was indeed a bad stepper, unfortunately the connection for the stepper was buried in the pull chain and had several levels of heat shrink on it. Once that was all removed I redid the connections to no avail. Ordered a new stepper, did a temp twist connection and boom, love from Y1 stepper. Now its time to break and put humpty dumpty back together again.

Pros of doing clean and final wiring: Its clean and final and likely not to be the issue in the future.

Cons: When you need to replace something its a lot of undoing.

1 Like

I hear ya. For complex but uninteresting reasons the power cord to one of my spindle motors is buried inside the drag chain under several layers of heat shrink. I trust my own soldering, but it makes me queasy and I would not want to open it up (first gen x-carve, no way to open the drag chain, I’'ll have to cut the cord to r&r the 611 when it gives up the ghost).