Issues with size

I just got my second X-Carve because my old one was destroyed during the move. My new x-carve has multiple issues, but the main concern is the cutting area not being the same size as my Easel project. Trying to cut out a simple box (see uploaded image) is supposed to be 6.6 X 6 inches. However, when the machine goes to cut it added 4 more inches I measured the cut and it was 10.6 x 10 inches. This happens with any project have tried. I rechecked calibration and belt tensions.

Additional issues with this X-Carve: Lost Z-Axis during cut, Z-Axis wired backwards, cannot use Probe because it causes bits to break. X-Carve arrived with broken Z-Axis motor and damaged power supply. Still no words back from the support team. They were emailed on the 30th of January.

which xcarve do you have now? you can set up each of job size here

Hi Alex, welcome to the forum.

the reason your carves are the incorrect size this that when you performed the “Machine setup” the wrong version of the Xcarve (or the incorrect upgrades) were selected.
You can got to Machine at the top and then select the existing profile(s) and then go to Edit Machine and delete them all.
and then Go to Machine>Setup New Machine and make sure to select the correct Xcarve version. IF the Xcarve you have now is the newest version with the Linear Rail Z and the 9mm belts, then you can select the “November 2021” version IF it does not have both of those upgrades, then you’ll need to select the “Pre November 2021” version based on this selection Easel WILL change the settings that effect machine calibration.

Regarding the mis-wired Z Stepper. . . there is also a step in the machine setup where you are asked to verify the correct direction of each axis and based on your answers to these test questions, Easel will automatically Invert the axis movement for you and save these this way onto the CNC itself

Can you share your grbl settings before doing the new machine setup>
Go to Machine Inpsector (Ctrl+Shft+D) and scroll to the bottom. . .

1 Like


That fixed the issue. Thank you. Ive wasted over 200 dollars in bits and wood trying to figure this out.

I forgot to capture the information prior to clearing my old setting. Sorry.

1 Like