Issues with Zeroing Machine

I’ve looked around to see if there is already a topic that covers this but I couldn’t find one so here goes…

I’ve finally gotten my machine assembled and this morning did a dry run on the “Hello World”. Everything seemed to run fine but after I did the air-draw, I tried to zero the machine to do the real first pass and when I clicked “Return to Zero” my machine decided to do a full runout of the Z-axis in the positive direction. I couldn’t find a way to implement a “STOP” command in GrBL quickly, so I unplugged the machine.

Thinking that I did something wrong, I reset everything, set the machine up again, and the same thing happened. Any idea what is going on here?

Also, i am a little confused about the zero operation as a whole. I use the jog functions in GrBl to get my machine where I want it and click the “Reset Zero” button in the Machine Command interface, which sets the work space zero and not the machine zero, but whenever I click the “Return to Zero” button, the machine goes back to the machine zero instead of the workplace zero.

Any thoughts or ideas on these two issues? I’m really itching to make my first cut but I also don’t want it to be my machine’s last. Thanks in advance.

What software are you using?

I’m using the Universal G-Code sender version 1.0.7. I’m following the procedure outlined here…

http://docs.shapeoko.com/helloworld.html

Two things to try:

  1. When you touch off 0 go to the tab where you can enter g code and type G92 X0 Y0 Z0. The G92 command sets the absolute 0 to that location. Then proceed as you were. If this works it means absolute 0 is set to a different location.

If that does not work then try…

  1. As a test after that can you please try Easel and see if you get the same results?

If Easel behaves the same way you may need to reflash GRBL 0.9 as it might be corrupted on the Arduino.

Sure thing. I’ll try it tonight and post what happens

So I tried the first thing that you recommended. It does the same thing as the “Reset to Zero” button on the machine control tab. It only resets the work position. “Returning to Zero” still sends the machine to the machine position zero, not the work position zero.

Alright, I just did a test run with Easel and had it do a simple square. Everything ran fine. So, is it fair to assume that the issue is with the Universal G-Code Reader? If so then any ideas how I can get that fixed?

I think you have an absolute 0 set or a work offset set.

Check these two links:

http://www.mmattera.com/g-code/gcodes.html

I get what you are getting at but I am a little confused with your wording. What are you referring to when you say “set” such as Absolute 0 set or a work offset set? Are you trying to say that I am using the wrong commands when I am telling the CNC to return to 0? If that is the case then does that mean that the wrong command is mapped to the “Return to Zero” button in the Universal Gcode Sender GUI?

UGS 1.07 is pretty old and may not be compatible with the newest version of Grbl. I’ve seen other users have weird problems with UGS 1.07. Since it works with Easel, it’s pretty safe to conclude that its UGS. Simply download and use the newest UGS version.

Just to be clear, would that be 1.0.8? I see some notes about a 2.0 but I don’t see a place to download it on GitHub.

Another note, a friend recommended that I try Chili Pepper. I looked through it and it now supports GrBl. Any of you given that a try?

Chilipepper has a pretty slick interface, but it requires a lot of graphical power to run it. It also doesn’t communicate to Grbl (or TinyG) directly and does it through a seperate serial interface server you have to install. This could be problematic if bugs come up. IMO, it’s nice and very ambitious, but there are too many moving parts that can potentially break. Eventually John Lauer may get these figured out (or has already), but I’d stick with GUIs that are time-tested and have a large user base, so you aren’t the guinea pig that finds the bugs.

Yeah, I was really blown away by how much ChiliPeppr seems to have up front but it does look very messy on the back-end.

Just to reiterate about UGS, is the most up-to-date version 1.0.8?

The latest stable release is 1.0.8

2.0 is a nightly build and therefore in beta… I would stick to stable releases.

Gotcha, thanks. I’ll give that a try.

Is your gcode file using inches by any chance? I believe what you’re seeing is UGS raising the tool 4 units before returning to zero. 4mm is fine, but if the machine is in inches then “4” is too big. I believe the current version resolves this by remembering the highest point while running the program.

If you’re still having problems just create a ticket on the UGS github, things like this are easy to resolve once I know there’s a problem.

Ok, so I updated UGS to 1.0.8 and I flashed Grbl 0.9g to the Arduino. I can connect to Easel and I can connect to UGS but I cannot get the machine to move. Anytime that I send a jog command in the Machine Control interface, nothing happens. The Active State goes yellow and states “Active State: Queue”. I have reset the system and I have restarted my computer two or three times but the issue remains. Any ideas? I couldn’t find anything on the Grbl or the UGS GitHub pages regarding this issue.

Do you have both open at the same time?

First in Easel click carve and click the button to unlock the motors. Then see if you can jog with the arrows.

Which button?

I made sure to not have either of them open (knowing that the same kind of thing will happen with two tabs of Easel open).

This happens right when my computer is booted up and no other programs are active.