It seems like my z axis is slipping

Hey all so far my x=carve has been running ok. The last two projects I tried to do was engraving. I set the depth and it seemed to cut deeper than what I told it two. The second time I tried it the z axis didnt pick itself all the way back up and cut across the piece. I tightened all the belts and i made sure the little nuts in the motor pulls were tight. I also checked the eccentric nuts and they all seem fine. Any tips will help.

Checked motor pinions aren’t slipping?

Based on how you are describing it (not picking itself all the way back up) I’d start with the wire terminations both where the Z motor terminates to the little screw, and where they go into the controller. Make sure they are tight and can’t wiggle at all.

With one of the 4 wires loose the stepper will move, but will loose control of direction it is turning.

Thanks for al the help. I just checked the wiring it all seems likes it tight. One of the wires had small tear in the outer case so i put electrical tape over. Im gonna test to see if that helped.