I've read many threads on troubleshooting home sequencing but can't find a solution for x-controller

Hi there,

I’ve read a number of threads offering solutions for troubleshooting home switch problems and most of the solutions involve Arduino and GRBL to help troubleshoot the problems. Will those solutions work for someone who has an x-controller?

More specific, my y-axis fails when going through the homing sequence. I had my husband check for continuity on the switch and wires and they both work. We also tried swapping out the y and z switches and the switch worked as well.

Maybe we’re not understanding how to troubleshoot. A lot of the answers assume we have knowledge in programming and running commands in line - which we don’t but would probably get if explained.

Thanks and much appreciated.

For the Xcontroller, check that the ribbon cable between the board you screwed on the power supply and the main board is securely seated on both sides. The locking clips will pull up before it’s fully seated. I like to pinch from the bottom of the board to the ribbon connector so the board gets supported.

Read through all three threads and you should be able to debug the problem.

For the X-controller with grbl version 1.0c set the status report mask to $10=115

Changes for 1.0c (X-controller)

Thaknks guys

BTW. Fixed the problem by upping the potentiometer to the y-axis limit switch to 4.

Most likely bumped a cable when inside the X-controller.

@Sharbuxx You should go back inside the X-controller and make sure that the cables are fully seated in their sockets, or this problem may return.

My guess is upping the potentiometers gave the y motors enough power to do its job. We did nothing else but open up the box and adjust the potentiometers

Are you running 2 steppers off of 1 driver or each motor on its own? Setting it to 4A per motor might not be ideal…