I've tried everything my Z Probe hardware dosn't work. Z Probe info

I read about a lot of issues with the Z probe. Most of them deal with issues in getting the hardware to work or in figuring out how to test the hardware when it doesn’t work.

I think this comes from a lack of understanding about how the hardware works, and then how the software uses that hardware to get you that spot on Work Zero Z.

Since most new X-carve users seem to elect the X-controller, let’s take a look at it as it operates a bit differently than many CNC controllers.

Here is a diagram that illustrates the Z probe hardware as it is implemented by the X-controller.

We’ll start at the X-controller and work our way out.

The kit that Inventables sells contains two main pieces of hardware, I’ll call the one that mounts on the X carriage the “socket” or female connector and the other one I’ll call the “plug” or male connector. These are my terms and you will most likely hear them called other things (hopefully not surrounded by a lot of four letter words).

The socket is connected by two wires to the X-controller. A ground wire and a signal wire. The ground wire is attached to the GND terminal and the signal wire is attached to the PROBE terminal on the X controller input block.

You thought I was not paying attention, huh. Didn’t think I noticed that the socket has three terminals. What’s that all about? I’ll get back to that.

When you power up the X-controller, grbl sets the PROBE terminal to a logic high state (we can just call this the “not tripped” state) and indicates that the probe input is not detecting the mill/bit in contact with the touch plate.

When things are working correctly then as the mill/bit touches the touch plate then the PROBE terminal circuit will close and the PROBE terminal will change to a low state [ground] (I’ll call this the “tripped” state). When the mill/bit is backed away from the touch plate then the circuit is “open” and the PROBE terminal returns to the “not tripped” state.

Woah! What’s that all about? It’s as simple as a flashlight. When you have the flash light switch off - no light. When you have the flashlight switch on - light.

The clamp on the spindle and the touch plate act as the flashlight switch and the PROBE terminal acts like the light bulb.

Mill/bit touches the touch plate, probe is tripped. Mill/bit backs off the touch plate, probe is not tripped.

Thought I forgot about the third wire, huh? Inventables, for some design reason, decided that they would rather have the normal state of the PROBE terminal tripped when the probe wiring was not in use. If you unplug the clamp/banana plug portion of the hardware the third wire ( R ) in the socket will connect the signal wire to ground and cause grbl to see the probe input as tripped. Once you plug the clamp/banana plug, plug back into the socket then that forces the connector to release the hardwire tripped condition (pin R disconnects from pin S) then the system allows the touch plate to work for your probing operation.
NOTE: This is an Inventables design/operational procedure. Not a common CNC practice.

There is another side to this. Software. Ugh. In order to accommodate the Inventables design you must also make sure that grbl reports the state of the PROBE terminal to the software if you are using EASEL. This is not an issue in grbl version 1.1f, but it is a problem in version 1.0c Just make sure that you have the grbl parameter $10=115 when you are using EASEL to get the PROBE function to work with grbl version 1.0c.

This should give you enough information to be able to trouble shoot your hardware issues.

Arduino/gShield does not have the Inventables issues so PROBE operation there should be a bit more straightforward, as far as the hardware is concerned.


Sorry, I am still lost. I connected the pride as the instructions except my “plug and socket” do not go through a plate - I do not have the newer router/spindle mount plate. When I go through the machine setup, I get to the “touch the touch plate to the collet” and NOTHING! I measure resistance and there is resistance not an open circuit. What am I doing wrong?

Did you try sanding the paint off the nut on the collet. The paint is pretty thick and will cause problems with the connection.

1 Like

No, I will try it. Thanks for the instant reply!

1 Like

Wayne, I tried it but it didn’t help. After a lot of troubleshooting I found one of the wires ha a fault. Put a new one in and runs fine! I really appreciate your rapid response. It kept me going.

1 Like

Which wire had a fault? Was it inside the X controller or one of the wires run between the socket and the Xcontroller?

I’m having the same issue and have tried two different Z probe kits trying to dial it in.