J Tech 2.8w X Carve

Hey guys. Finally got my JTech kit mounted to my X Carve and was looking for some help from anyone running PicEngrave Pro 5. I am trying to find the best settings for engraving images. Right now I am testing on scrap MDF and Select grade 1 pine. Once I am comfortable I will be using chestnut for several projects. The main issue I seem to be having, and it may be me, is that no matter what I set the feed rate to it seems the X Carve wants to go full bore all the time. It’s like its taking the max rate from the grbl settings and ignoring input from PEP5 or PicSender. I am also noticing stripes on some of the Text I have been writing but believe this to be because I was just using horizontal engraving for a quick test. I am using the 1000mm Xcarve. Current settings are

Max feedrate= 80.inches
Pixel Resolution= 0.006
Max PWM Value=255
Min PWM Value=10
Laser Off=0

Gcode options Checked are - Spindle on/off and comment gcode
No engraving options checked
no laser options checked
Using GRBL PWM profile

Thanks for the help.

I was checking PicSender web site, I found this may help you while you’re waiting more help.


Which GRBL firmware do you have installed?

I’m using the Jtech Hex from picengraves site. I believe its .9i

Hi Rick,

Can you post the comments at the top of the gcode file and the first 10 lines or so of the gcode? Can you post your grbl settings also?

Edit: Also read through this thread as it gives some recommended settings in PEP5.

The commands used for the J-Tech PWM grbl is the same as the EmBlaser’s grbl. The J-Tech 2.8W laser and the EmBlaser uses the same Nichia 9mm laser diode also.


Thanks Jeff. That post is actuall where I came up with some of my base settings. They seem to work for the most part aside from the speed issue. I was also just looking to get the best quality image possible with my setup. Here is the gcode generated by PEP5 for an image I am testing with

( PicEngrave Pro 5.0.23 - for MS Windows US Version )
( Date/Time: 10-12-2015 at 14:49:08 )
( Image File: food_2test )
( Image size in inches: 3.378w x 1.35h )
( Pixel Resolution: 0.006 inch )
( Line Spacing: 0.006 inch )
( Max. Cut Depth: 255.0000 inch )
( Min. Cut Depth: 10.0000 inch )
( 3rd Axis Safe Position: 0 inch )
( Start Position: image bottom left )
( Horizontal Axis Offset: 0 inches )
( Vertical Axis Offset: 0 inches )
( Engraving Angle: Left 45� )
( Spindle On/Off Enabled )
( Inch Mode )
( X Axis Align 0 )
( Y Axis Align 0 )
M03 S0.0000
G01 X0 Y0 S0.0000
X-0.006 Y0.006 S0.0000
X0 Y0 S216.5686
X0.006 Y0 S217.5294
X0 Y0.006 S220.4118
X0 Y0.012 S221.3725
X0.006 Y0.006 S220.4118
X0.012 Y0 S217.5294
X0.018 Y0 S218.4902
X0.012 Y0.006 S220.4118
X0.006 Y0.012 S221.3725
X0 Y0.018 S222.3333
X0 Y0.024 S222.3333
X0.006 Y0.018 S222.3333
X0.012 Y0.012 S221.3725
X0.018 Y0.006 S220.4118

Here are my grbl settings

$0=10 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=3 (dir port invert mask:00000011)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.020 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$14=1 (auto start, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=40.000 (x, step/mm)

$101=40.000 (y, step/mm)

$102=188.972 (z, step/mm)

$110=5000.000 (x max rate, mm/min)

$111=5000.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=500.000 (x accel, mm/sec^2)

$121=500.000 (y accel, mm/sec^2)

$122=50.000 (z accel, mm/sec^2)

$130=790.000 (x max travel, mm)

$131=790.000 (y max travel, mm)

$132=200.000 (z max travel, mm)


Hi Rick,

I don’t see anything that stands out in your PEP5 settings that would cause the feedrate problem, but try changing to these particular grbl settings and test again.

$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$10=18 (status report mask:00010010)
$11=0.005 (junction deviation, mm)
$13=1 (report inches, bool)
$120=12000.000 (x accel, mm/sec^2)
$121=12000.000 (y accel, mm/sec^2)

You can change them one at a time with the Do Cmd window & button in PicSender.

Also if you want the best quality engraving, use the Feed Rate Change in the engraving options which will expand/enhance the shades. Set it to 25%. You will have to switch to the Analog/PWM profile to use it. Bump your Feed Rate up some too. 90-100?

In Precode, I input a G90 G94 there.


I will give that a shot. If I may ask how many amps are you pushing to your laser?

When I was using the J-Tech Laser on our Shapeoko, the driver was set at the default 1.5a.

Here is a video of it with the settings I recommended to you engraving on Poplar.

Thanks for all the help. I do have a very specific project that I am working on that is chestnut. Do you think I will have issues with this?

We never tried engraving on Chestnut. Different woods engrave differently and requires trial and error testing with the feedrates and power levels. How you edit the image plays a big factor into the results also. Sharpen, Contrast, Brightness and Gamma adjustment is in the PicEngrave Pro 5 image editor. The image editing is in the eye of the beholder and is the hardest to teach someone. You will just have to learn from your own testing using your laser and materials.

Thanks again for all the help. I really appreciate it. You have a fantastic product.

1 Like

So I ran the program again and I am having some issues. Maybe you could advise me in what direction I should go in regards to settings. So when I run it on analog with feed rate change on the Z axis moves up until it crashes. When I run in grbl PWM mode I get an image that looks like this

This is the stock image

Any thoughts?

Did you change the 3rd Axis Letter to S instead of the Z in the Analog/PWM Engraving Profile? The S letter is what commands the PWM from a range of S0-S255 with the J-Tech LaserMode grbl.

Your engraving looks like the laser’s focal point is not at the smallest size possible. Try engraving at different angles. The J-Tech lens does not quite focus to round spot. It’s slightly oblong.

Thanks. I will test this tomorrow. To me it looked like its only able to do dark and light the way I have it set up, not grayscale. Thanks for pointing me in right direction.

OK. So I finally had the chance to play with the X Carve again. Things are better but I have a new issue. It seems to be more X Carve related. The movement has become very stutter y. Its very jerky and I checked the belts and they are fine. Any Ideas? Thanks

Hi Rick,

Can you verify the grbl settings I recommended are still set the same way and you are still using the J-Tech PWM grbl?

You state it’s a new issue, so I’m just wondering if something has changed.

Certainly sounds like you are running standard GRBL and its pausing and stuttering as the S commands are sent.

I will check that today. Another strange issue is when I create the link from picsender to the xcarve all the stepper motor lights come on and the steppers make a high pitched noise. I end up having to jog them to get the lights to go out and the motors to unlock.

The lights coming on is normal. It just indicates PicSender has connected and took control over the UNO and gshield. You will notice when jogging slow, they will flicker on/off when moving the axis’s.

You may have to adjust the amps higher on your gshield with the pots for the steppers. Sounds like your trying to run a higher feedrate then the steppers can handle at the setting they are now. With an increase in the accel settings for the X&Y axis and using a higher feedrate for laser engraving, you may need to adjust them accordingly.