Inventables Community Forum

J-Tech 3.8 not working with X-carve

Can anyone help ? I have X-carve , j-tech 3.8w laser & lightburn installed , 1.1g grbl & I can not get the laser
working for love nor money ! all settings changed in lightburn as per instructions . Problem is I am only showing 2.15v at the back of X-controller when testing spindle PWM & Gnd with the multimeter J Tech say I need 5v for it to work ! image|400x300
image

I am at a loss as to why ? They were bought new from Robbosavy Sept 2017 & for reasons I won’t go into I have only just been able to set up the laser … still in the packaging & still brand new , first off nothing would work , after a day or so thinking I had set Lightburn up wrong , I got in touch with Jay from J-Tech & got to say he has been very good at replying etc ! After trying the tests I eventually found out that the new plug was not working So Jay kindly sent another out ,which off the bat worked the lights & fans on the laser , but now it still wont fire & after Jay talked me through the tests We have now got a lack of power at the said back connectors ,Any one got any ideas ?

what version grbl are you running on the cnc? (shown in the upper portion of machine inspector)

Oh and what program are you using to run the laser?

And what power are you running it at when your reading 2.15v?
and I’m assuming this is a DMM not an analog MM in which case the way the PWM works, by sending alternating 0v and 5v signals to identify to the laser what power it should operate at, it would only read 5V IF its et at full power (and Laser max power would be 1,000 based on your $30 setting in that photo)
So if your using lightburn by chance you’d need to set the SMAX value to 1,000 in the settings.

1.1g grbl
lightburn
2.15v after sending full power code G1 F100 M3 S1000 in lightburn
SMAX set at 1000 in settings as well
After speaking to Jay at J Tech again & having a quick look for answers on here & other sites I am hoping the ribbon cable in the x-controller has not been seated well enough ! I will have a look today , I am probably wrong here , but a wee bit confused as to why it would show a different reading eg . going up to 2.15v after sending the code .If the ribbon connector wasn’t fully seated would the v go up at all ?
Any other ideas SethCNC ? I appreciate your help Cheers :+1:

1 Like

Opened up X-controller no sign of anything slack ! Not quite sure why Im not getting the 5v ! Anyone ?


well, since your in there you might as well turn on torque locking in the event that you ever plan to do multi bit carving…Here’s How > How to fix X-Carve Lock Motors Fault For Stress Free Bit Changes - YouTube

I’m not entirely positive of this, but since that is a 5V circuit I wonder if it’s powered by the USB itself and your PC is not sending adequate power maybe? just a guess really as that ribbon is very close to the USB connector above and it’s known that the 5V from the PC’s USB is powering up the Arduino chip in the top board. If you have a powered USB hub, a sorter cord, or even a different usb port, maybe give that a shot an see if you get different voltage readings? I don’t have that laser, instead I have a standalone Laser Engraver machine :man_shrugging: so from this point I think I step back and tech support might have an answer for you when they are open tomorrow

1 Like

Cheers anyways SethCNC :+1: appreciate you trying to help ! its getting a bit frustrating now , Will see if anyone can come up with the answer :man_shrugging: really dont like the thought that I have spent £500 on a new laser that might not work !!! :crossed_fingers:

Shot in the dark but your $1 setting is at 255 is it set the same in Lightburn. It can be set at 255 or 1000 but both need to be set the same.

? According to grbl documentation $1 valid values are only 0-254 and 255 for infinite hold time.

Setting it to 1000 would be an erroneous entry

1 Like

Your right my mistake i was thing of $30. Went out to check my settings.

After putting back together & sending G1 F100 M3 S1000 repetedly I am getting 3.2v consistantly from X-controller & laser controller . Is it possible that this X-controller does not have enough power to fire a 3.8w Laser ? I thought that everything had been done as recommended …but now have no idea what is happening ,it seems odd to me that manual setting can burn no problem , that lightburn is sending what looks like the right movements but there is this lack of power ! Has Anybody got ANY idea of whats going on with it ? Im stummped :man_shrugging: , was told the x-carve would power the J-Tech laser & Lightburn was good for the J Tech :man_shrugging: If anyone can see anything I have done wrong it would be appreciated …It’s certainly not beyond my capabilities of making a blunder somewhere :grimacing:

1 Like

I run a 7w Jtech on mine and ran one on my old 2015 with the old controler so that would not be the issue. Will it burn at all or nothing?

1 Like

Hi Wayne
Itll burn on manual but it will not even fire when going through lightburn . It goes through all the motions but it no laser :grimacing: seemingly I am just short on Volts as it needs 5 for the laser to fire :man_shrugging: J-Tech think it might be a faulty output on the X-controller

:man_shrugging:

1 Like

I would recommend you post on the LIghtburn Forum and/or talk to Jay at J-Tech he’s very good and patient.

I have a 7W laser from Jay and it works very well with Lightburn.