Jtec Laser

I am having trouble getting a laser beam on low power to set a home position and tune the laser, I send the command M03 S3 but I am not getting any beam, it is working fine apart from the beam with low power, does anyone have any advice

what is your max RPM setting in GRBL? does the laser come on full power when switched to CW on the switch on the power converter?

what is the laser like with M03 S1000?

Yes laser comes on full power when in CW, I tried the command MO3 S1000 and still no beam, $30=255

how do you have your laser connected to the controller? do you have the X-Controller or an Arduino-GRBL board?
sounds like you might not have it wired correctly.

Sounds like you are running grbl 1.1f. It is quirky when it comes to operating the laser.

You can either switch to my 1.0c version with laser support and things will work normally, or I can point you to some documentation that describes the G-code changes that 1.1f made to the way G-code operates with the laser.

Which way do you want to go?

Kenneth, I have the X-controller and I am sure it is wire correctly
Larry,yes I am running grbl 1.1f I would like to switch to the1.0c version if that works ok, how do I do that

You would use Xloader to flash the firmware into the X-controller. What you would lose by doing this is the ability to use feed rate and spindle speed over rides. Those functions are unique to version 1.1f.

Here is the page where you can get my version and Xloader if you don’t have it already.

1 Like

I always here you say that and I do not want to argue over it, but what is quirky with the 1.1f I am using the version from inventables and have not had any problems with it at all. I have done several projects with the 3.8 laser and have always been happy with the results.

Just wondering if I am missing something that I am unaware of or am I just lucky.

No problems here.

When Sonny implemented the laser code in 1.1f he included some changes to the way G-code works in order to include some safety features. Safety features are not a bad idea at all, but there are some problems with the implementation.

First problem is that he changes the way some of the G-code commands function which are not in accordance with the G-code spec that grbl is based on, so if you have a program that generates G-code by the standard, then it will not function as expected when run via grbl 1.1f when running in laser mode (spindle mode works well with no issues that I know of).

Second problem is that there have been reports of lasers turning on at full power when it was not expected by the operator when using 1.1f. This one is the one that really bothers me.

G-code generating programs have to be modified to use the laser properly with version 1.1f. An example of a program that does this is PicSender. A program that does not do this is the Vcarve flavors. I haven’t really looked into it, but it might be possible to make a Post Processor for the Vectric products to handle 1.1f with the laser. But the high end software folks are probably not going to go to the effort for a machine like the Xcarve.

It just makes me nervous that someone could get hurt if they don’t know the characteristics associated with using a laser with 1.1f.

That’s not to say that people can’t be hurt using my version, but if they know G-code, my version will function deterministically the way that the standard G-code commands work that they are used to using.

Case in point is this thread. My guess is that when Patrick loads in my version and does his M3 S(nnn) the laser will come on at that power level. You have to do more than that to get the laser turned on with version 1.1f. We’ll see. I think he is going to load my version.

That’s my take on it.

Here are the conditions for operating a laser with grbl version 1.1f and you can draw your own conclusions.

2 Likes

LightBurn works correctly with 1.1f, and uses the M4 command which has the proper safeties, instead of M3, which can leave the laser on when paused. If you’re going to use a laser, it’s likely safer to use the 1.1f firmware with a program that uses it correctly, and the firmware in the appropriate mode. (LightBurn expects $32=1, $30=1000, the latter being the GRBL default).

1 Like

Yep, I need to use S10 as well, otherwise I can’t see it.

@PatrickDunne

are you using an O “o” or a 0 “zero” in M03. it needs to be zero or just try M3

I am at work and can not try it right now but I think I just use M3 to turn on the laser.

I meant M3 not M03 so when I do it under UGS I send M3 S03 at the command and press enter

1 Like

Laser mode in GRBL has two params - spindle min, and spindle max. If your laser has a firing threshold, you set that value in spindle min, $31. When software emits an S value greater than zero, it gets mapped to the range between SMin and SMax. My CO2 laser has a threshold of about 12% (would be about 30.5 in the 0 to 255 range).

Thank you all for your help,I have not been able to try anything yet as my workshop computer packed up this morning and I had to replace it and I am still installing stuff on it, I only have to install UGCS and I am having trouble getting it to work, I have downloaded it and extracted all, but can’t seem to get it to open, I will keep trying, I do intend to use piclaser when I get everything running

1 Like

Did you install Java?

Yes, I installed Java and downloaded UGCS from a link on the J-Tech website, then extracted all, when I try opening I get a list of all the files, I must be doing something wrong, I will try again Tomorrow,

that is probably because what you downloaded was a compressed archive (zip) file. this is a single file that contains all the files for your extraction.

extract all the files and then run the executable for your system (start-windows for windows system) (start.sh for Linux and Mac)

full instructions can also be found if you read the entire article at https://jtechphotonics.com/?p=4910#download

windows-start.bat but more likely than not he will not see the .bat extension in a windows file system (unless he has that turned on) it is off by default. the .jar is the actual file but it is wise to run it from the batch files as there is more to the command than just running the .jar

if you want just open either the windows-start or the start.sh in a text editor and you can see what the long command is. it is mostly run time variable’s for ram etc.

so you could just run the .jar but it would most likely run better from the batch files.

I downloaded UGCS again from the link on JTech website that Kenneth mentioned, they recommended 1.0,9 and that worked fine, I have been trying for a long time to get the laser on low power sending M03S10—M03S120----M3S10 --M3S100 and none turn the laser on, my settings are $30=255 $31=0 $32=1
so I tried to load Larry’s 1.0c on to grbl with his X loader, but had no luck with that either
I loaded
uno/ATmega328 --COM 3 baud rate115200 which are correct as the laser is working perfectly on those settings
in the Xloader I typed E:\Xcarve_JTech_grbl_9_1_2017
is all this correct