Jtec upgrade was going good until

Hi There, I was having the same problems as you with the J tech hex file, when trying to move the machine it was making really high pitched noises but not really moving at all, the steppers were singing, I changed the acceleration defaults in the GRBL settings in pic sender and this seems to have cured the problem, I found the accel rates were way to high at $120=8000.000mm/sec and changed them to 50.00. the machine started to move again without singing.
I’m just having trouble with laser engraving now, I have setup a picture in picengrave and it should engrave about 100mm x 70mm ish but it seems to be engraving it really big, must be a setting somewhere I think.

1 Like

It has to do with the Pixel Resolution (stepover) setting. If you use a .254mm PR, it will engrave the same size as your image. But, if your laser’s burn line width is narrower then .254mm, you will have to reduce the PR and resize your image in the editor to compensate. Instructions how to do this is in the Tutorial on page 7.

1 Like

You should not be changing the Pixel Resolution setting to adjust the engraving size. That setting determines the step over when it generates the gcode and it would be based on your laser’s burn line width. If set at .01" or .254mm, it will engrave the same size as your original image. If you use anything other than those values, the image editor should be used to resize your image instead.

The PicLaser Tutorial is accessible in the Help menu and it has instructions how to do this is on page 14. The Tutorial was added recently, so make sure you are running the latest v2.1.2.

www.piclaser.com

1 Like

I have tried the pixel resolution as you have suggested and I’m still not having any luck with the laser engraving picture being too big, I have the X Carve 1000 x 1000 and the J tech 2.8w laser kit, I’m also running the j-Tech Hex file… I am using pic engrave pro 5 and picsender, I’m not at the machine at the minute but the only thing I can think of is looking at the above post on shanebell’s settings to mine is his step settings are $100=40.000 (x, step/mm)$101=40.000 (y, step/mm) and my step settings are $100=250.000 (x, step/mm) $101=250.000 (y, step/mm) would this cause the engraved picture to be massive compared to what it should be?
Also I read in the help file that x and y 0 is bottom left hand corner of machine as you look at it, when laser engraving the machine starts from top right hand corner and works right to left and from top to lower left corner and image is upside down?? is this normal?
so as I start the engraving I have to move the machine up and to the right I press send in pic sender and because I think the problem could be the step settings too big are making my engravings huge and the machine just moves to the left y rail and crashes into it.
Any help with this would be brilliant.
Thank you.

OK, that is why your steppers were singing with the higher accel settings.

Here is the default settings for the 500mm. You will need to change the $130= (x max travel, mm) and
$131= (y max travel, mm) for your X-Carve size & travel.

Use the yellow GRBL button in PicSender and make the changes in the left window. After getting the default X-Carve settings changed back, use the Save to backup the settings.

Here is the recommended grbl changes when using the J-Tech PWM grbl, so make those changes, then back them up also and then select Send. The instructions will explain how to change back and forth with the different grbl versions also.

1 Like

grbl.hex (76.0 KB)
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)
$N1=F4000 (Default Feedrate)

I’m also having issues with PicSender with the x-carve. No problems when using Universal G Code Sender with my Dewalt router but when I added the JTech Photonic laser and downloaded Pic Softwares (purchased Picsender, PicLaser, PicEngrave Pro 5). Now that just opened up a whole new can of worms!
I searched youtube for some type of video tutorial on setting up PicSender to work with the X-Carve and JTECH laser. But I could only find jtech laser installation on x-carve and at the end of the video is a demonstration of the jtech laser etching/engraving a piece of wood, no software setup.
Could someone create a video tutorial on PicSender software setup for the x-carve with a jtech photonic laser upgrade?

Select the info button bottom right on the main screen. There is a Tutorial PDF file in there that you can open up and read how to use PicSender.

1 Like

I would be happy to make a vid but I will not be running the laser till this weekend. The instruction really is straight forward I just had to reread it a million times because I was over thinking the setup and made it more complex than it really was. It will drive you to your wits end that i will promise you. After you get it up and running you be in the face palm position

1 Like

Thank you! Will look into it.

Thank you! I’ll be looking forward to seeing your video tutorial!

1 Like

Well this is awkward. guess no vid till I can figure this issue out. A lot of the same issues as when I first set this up. It all goes good till I try to change the grbl settings for the jtech.hex the header info I think it is called but the hex uploads just fine but tried to send the modded header info in pic sender and all goes good reports back ok then I check it and it is still the old settings kinda at a loss.
UPDATE:
I think I may have figured it out we will find out soon enough

Ok so I downloaded the firmware for jtech (still have no idea how to use the laser) but more importantly now easel won’t recognize my Xcarve since I downloaded all the necessary stuff for pic laser and sender. Any thoughts here? Being an engineer I feel pretty dumb I can’t figure out the laser at all

As far as I know you have to switch back and fourth between firmware and sometimes it can be a real PITA. And don’t feel bad being a engineer everyone has their kryptonite. I have not had my laser up and running for a few months and I am going through the same things but it’s all coming back to me. Once I feel confident on the setup a vid will follow. But believe me and I think you know the first time around can be frustrating.

I’ve been trying to run my laser for a few months now also, downloaded everything as it said and nothing. It is beyond frustrating as everyone using it makes it seem so simple and I am getting to the point of utter annoyance with the fact I can’t figure it out

I finally got the files figured out for mine I had too many copies of too many versions so here are the hex files I am using with no issues at this moment. after switching run machine setup in easel for the inventables hex file

inventables grbl0_9i_X_Carve_500mm_ACME (1).hex (80.3 KB)

jtech grbl.hex (79.1 KB)

and here is xloader XLoader.zip (678.3 KB)

1 Like

I still have Grbl 0.9J on my X-Carve. Would it be safe to install Grbl 0.9G and will it work fine with both Universal G Code Sender and PicSender without jogging from 0.9J & 0.9G with a peace of mind of using both spindle router and laser engrave projects?

I hope that someone can give you a better answer than I could on that. I am using the above files because it has given me no issues. And after doing the switch a few times it only takes me a min or 2 to be up and running versus the days and hours it took fighting with the machine in the past and now after locating my correct files once more I am back on track.

I hope this can help you

1 Like