Jtec upgrade was going good until

will do and will report back when i run this process THANKS!!

If you have not updated to the latest version v2.3.4 of PicSender as of yet, I recommend you do that also.


1 Like

Well I will have to admit I have absolutely 100% no clue what so ever what i am doing looks like the only thing I have a grasp on is putting the thing together and reflashing the uno. back to the books of trial and error.

You may need to make some changes to the grbl settings.

I really hate to be a bother. Been reading what i can I dont know anything about settings or access to them. I am one of those people that could build optimums prime but spend weeks trying to figure out how to set the timer on the coffee maker.

Select the info button at bottom right. There is some basic instructions in there and a Tutorial for PicSender. The grbl settings you need change for laser engraving with the J-Tech firmware is here. Also there is instructions how to backup your current settings before any changes are made.

Some info on the default X-Carve settings for reference.

GRBL 9 configuration information so you know what the settings do.


Thank you for your time it is much appreciated.

Been doing some reading. tried once more Laser is on at time of turning on power. Z is locked and humming at power on.
Ran file took off in a straight line on the y axis and z went down and buried into the table.

$0=30 (step pulse, usec)

$1=255 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=3 (dir port invert mask:00000011)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=18 (status report mask:00010010)

$11=0.005 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=1 (report inches, bool)

$14=1 (auto start, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=40.000 (x, step/mm)

$101=40.000 (y, step/mm)

$102=188.976 (z, step/mm)

$110=4500.000 (x max rate, mm/min)

$111=4500.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=8000.000 (x accel, mm/sec^2)

$121=8000.000 (y accel, mm/sec^2)

$122=25.000 (z accel, mm/sec^2)

$130=790.000 (x max travel, mm)

$131=790.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

here is part of the file
( File: 974262083_7d4eea5d35_o Resized.bmp )
( 04-09-2016 at 10:18:19 )
( PicLaser v. 2.1.1)
( J-Tech 3D )
( FeedRate = 050 )
( Pixel Resolution = 100.0000 )
( Max. Laser Value 255.0000 )
( Min. Laser Value 0 )
( Engraving Angle = 45 degrees )
G1 F50
G1 Z0
G1 X0.00 Y0.00
G1 X0 Y100
G1 X0 Y200
G1 X100 Y100
G1 X200 Y0
G1 X300 Y0
G1 X200 Y100
G1 X100 Y200
G1 X0 Y300
G1 X0 Y400
G1 X100 Y300
G1 X200 Y200
G1 X300 Y100
G1 X400 Y0
G1 X500 Y0
G1 X400 Y100
G1 X300 Y200

Ok I got the z to stop going down but no other changes

Ok tried setting everything to metric It’s doing something but in a space of about .25x.25 inch and still have no software control of laser on and off in pic sender it is on at all times

In PicLaser’s Help, there is a Tutorial PDF that can be opened. I recommend you read through it. Page 9 has some starting point settings for GRBL. The final settings depends on the Laser Wattage you have and the material your engraving. Also with the Pixel Resolution (Step Over) setting shown, you need to re-size your image in the editor. Page 14 gives you instructions how to do that.

The J-Tech engraving profile is for 3D printer controllers. You need to be using the GRBL engraving profile in PicLaser. The Laser Power Command you should use is a S, not a Z. Spindle engraving a photo would require a Z and those recommended settings are on Page 10.

If you are generating the gcode in Inch units, then Metric needs to be un-selected in PicSender. When Laser engraving, GRBL PWM Code should be selected. When spindle engraving, select the GRBL Z Code,

Your GRBL settings look fine. Make sure you back them up in the GRBL menu.

Do you have the Laser drivers’s modulation input on pin D11 & ground on the UNO? Do you have the Mode Selector Switch on the driver set to CW Mode, or Input Control Mode? It should be set to Input Control Mode.

1 Like

Now things went south checked all settings read manuals no go. Spent hours trying to gain access to put the xcarve grbl back on could not open port finally sees port switched back grbl com 4 recognized. easel can not find it and the axis motors still locked not getting hot but humming with a click every few seconds. pic sender still can access grbl

Ok many many hours later I have got the stock grbl back and functioning so i guess i will be starting the processes over once more

1 Like

Ok asking for help has anyone got a test photo that is set for the jtech and xcarve using pic sender. At least it would give me some header code to reference by. And I have tried all setings and wiring laser is always on in cw mode. As soon as i turn it on ran code still on.

Here is an image and information to test the EmBlaser which has the same laser power as the J-Tech 2.8W. The settings shown should work close enough for you to test with.

There are two gcode files you can download from my last post this thread. One for Imperial units and another for Metric units.

1 Like

Thank you

Like I have said in the past machine errors are easy operator error is the hard part. After some reading it says i need to be in ttl but what setting do i use on the jumper j3 invert or non invert. And after a tear down and inspection I do have a authentic uno board.

Where did you get your Arduino from? Is it a genuine unit or a clone? This caused me issues for I don’t know how long. The Jtech GRBL will not play nice with a clone UNO.

I would think the J-Tech driver would come set with the default jumper setting for the X-Carve, but if it works in reverse than it should, change it.

1 Like

This is the actual SMD Edition UNO we purchased from inventables. It works flawlessly with the J-Tech PWM LaserMode grbl. We have been laser engraving images with our 6W LD @ 200IPM streaming X,Y & S command gcode files with PicSender. Our machine is a Shapeoko 2 driven with Nema 17 steppers & the gShield V5 stepper driver. Does your UNO look like this?

1 Like