Jtech laser (low power)

Hello group,
I moved my X carve with the j tech laser today and am now having some issues. The laser is receiving power and I’m able to control it through pic sender , but will not go above 600 power. I can get to S700 and it flickers, I’ve check all my wires , didn’t disconnect any but pin 12/14, which are easy enough to put back. Tried my best trouble shooting but no luck.
Thanks for any help or sudgestions !

I posted in upgrades , but this seems more fitting

Her are my current settings

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.005 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=1 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Will the J-Tech laser go to full power when the switch on the driver is set to CW (Constant Wattage)?

Have you tried resetting the UNO and re-flashing the firmware to the UNO?

1 Like

I haven’t re flashed, yes it does go full when I flip the the switch. I didnt think to re flash because of it receiving signal from the drive. And everything else works right as far as engraving and movement of the xcarve

As you know, the laser power is controlled by the PWM from Pin 11 & ground on the UNO, so It could be something in the firmware’s PWM out causing it, or the J-Tech laser Driver’s modulation in.

1 Like

So I reflased and still having the same issue, will get to around half power and cut off. When I run a gcode test, it will flash on for a half second and cut off.

You either have a failing J-Tech Laser driver, or the chip on the UNO for the PWM is failing. Do you have spare UNO to test with? Contact technical support at J-Tech Photonics and they can help you diagnose what could be causing it.