Jtech laser not firing

I just ordered the the 2.8 laser and everything seems to work with it turning it on and cw mode, but anything being done in the post processor part of v carve it won’t turn it on. I’d if I wired it wrong to the board for the pins or that my firmware is not set up for a laser. It’s a older xcarve that I picked up and the person that had it just put it together and did not use it.

Contact @JTechPhotonics. They did an amazing job with my issues. My TTL button shorted and able to help out.

I’ll have to contact them then. I don’t think anything shorted on it. I just think the person that owned it never updated the firmware to the new one in the xcarve for grbl and I’m still new to the whole laser set up.

also I’m pretty sure it should be on TTL not CW

You might need to check your GRBL settings. You can send a “$$” command to see them. Look for the following:

$30 (max RPM and Laser Power)
$31 (Min RPM and Laser Power)
$32 (Laser Mode)

We recommend that they be:

$30 = 255
$31 = 0
$32 = 1

You can change them by simply sending the command, like this “$30 = 255” to the machine. You can then check that they got set by sending “$$” again.

In TTL mode, you should be able to turn on the laser in low power by sending the following:

“G1 F5000 M03 S11”

If this does not work, then I would try sending it at full power:

“G1 F5000 M03 S255”

And then use a volt meter to check your connections. You should have 5V at pin 11 on the Arduino. The 5V should be on the G Shied as well and go all the way to the driver. Sometimes you might have a bad solder connection on the G Shield.

Let me know if you have issues with this. Give us an email at customerservice@jtechphotonics.com if you do.

Best Regards,
Jay

1 Like

Thanks for getting back with me, I did email you just a little bit ago. I will check that and see if everything is set up. If not will I have to upload new grbl with it set up for a laser and I will check the controller also to see if anything with a connection.

I checked my settings and there’s no set up for a laser input. Is there a newer grbl that I’ll be able to use the pin and laser mode? I think that’s my problem. The person I bought it from just put the x carve together and never messed with the settings.

Yeah I’m still new to it but just wanted to make sure everything powered up. First time messing around with laser engraving and the settings/set up.

Hi Joshua,

I don’t think you have the latest firmware as you don’t have the laser mode settings on it. When you start UGS, you should see in the console what version you have. You can update your firmware easy if you want by following the following post:

If you have older version of the firmware, you can still use it. Your settings are probably going to need a laser power or spindle speed of 12000. In V Carve, make your tool have this spindle speed and the laser should turn on. You can also send this in UGS:

G1 F5000 M03 S12000

and it should turn on.

Hope this helps!

Jay

Hi jay,

It was the firmware that gave me the trouble. I loaded up a version from a different foum post. I imputed the settings you told me to send into the command and it now turns on and off when I send the gcode in! Everything is working and now onto fine tuning everything for projects. Here’s a few test pieces I’ve done since fixing that firmware problem.

https://discuss-assets.s3.amazonaws.com/original/3X/2/4/24d4c68f9051ebbb94632b203ec9af2238c97c75.mp4

Awesome! Glad you got it all working now. Your logo looks great on your work!
Jay