Jtech laser problem

HI all. I have big problem and sorry for my english. I got Jtech 2.8 W laser and i can’t enable laser with M3 command in Universal Gcode Sender. I need to engrave simple vector signs on wood. I plugin + from laser board to pin 11 and ground to pin 14. I dont have 24v Spindle but Kress 1050 FME. I change grbl.hex with //#define VARIABLE_SPINDLE and still the same… what im doing wrong ?

I don’t know if this will help but give it a try. I use 0.9j grbl. I would recommend using it versus the JTech hex. Ensure your commands are providing an ‘S’ command for the laser after the m3/m03 command. With the 0.9j grbl you can use S1100 as max and around s75 for a decent minimum where there is visible laser light but it isn’t burning the wood. I suspect if you left it on long enough you may burn wood but I think you get the point.

One other thing to check is to verify the laser comes on without any code being sent. You can do that with the switch. I caught myself a few times trying to run code without first resetting the safety switch/button.

Good luck!

THx for reply. With 0.9j grbl i need to make new hex witht //#define WARIABLE_SPINDLE ? I try to send command with S and stil nothing. If i enable on laser board switch to CW laser is on, ( nice blue color :slight_smile: ) but i cant control it :frowning: ANother question, can You explain first resseting ? I push reset button on board, plug in power , and enable it ?

I am not familiar wit the #define detail you have. With the 0.9j you should not need to change hex at all. If you can get the laser to come on via the switch then the safety reset has already been done. There is a small push button on the driver board that is part of the safety feature(s). You may have purchased the optional push button with cord that will help you step away from the driver board but not necessary. I would recommend flashing your arduino with the 0.9j grbl and then try the jtech extension within inkscape. I generally have to take the code txt file and replace all the ‘S254’ with ‘S1100’ to get it to work better. You can also try software from picengrave.com. They have trial software that may help you in your troubleshooting to verify your laser is operational. If that doesn’t work, I would check your driver board and verify you have no grounds in any of your wiring.

Thx for reply JeremyHill. I solved problem !!!.. im so stupid stupid… stupid i am !!! i dont know what i do this but i plugin wrong cable !! (from limit switches :slight_smile: :slight_smile: now its work !! on 0.9 j without any modyfication, but now i have another problem and i dont know why… first i think that problem was with my play with gbrl … but i back to orginal 0.9j. Problem is with reverse move on manual control i have reverse X and Y axis. Only Z axis moved ok. If i send comand to move Y left they run right , and similar to X… if i moge forward they go backward :frowning:

Great to hear! There are some threads within this forum that discuss that reverse issue- wiring as well as code. You may want to search the potential keywords. I don’t recall which exact thread had it.