JTech Laser & Vcarve overburn

hi ya’ll

Burning text with 3.8 w and v carve 8.5 and im getting over-burn between the text,

the equivalent of the bit dragging through the job between letters,

I have the following settings.

spot diam = 0.254
pass depth = 0.254
nose cone ? =0.254
safe z = 0.254
home = x0y0z0.254

am i missing something to turn laser off between letters ?



What program are you using to generate the G-code? what program are you using to send the G-code? what it looks like is your minimum setting is leaving the laser powered on during the moves.

For example if your GRBL setting when issued a $$ command what are your settings on $30=? and $31=? mine are set at $30=0 and $31=255 this means that your laser is off when you send the M3 S0 command and is at full power when you send the M3 S255 command. when your software generates the G-code it need to turn the laser off between moves or turn it down almost off like M3 S01.

Which post processor did you use with Vcarve for the laser?

GRBL MM from the jtech website :slight_smile:

Vcarve pro 8.5 for Gcode,
PicSender with 1.0c for sending to xcarve

"I am using the laser mode of 1.0c , since vcarve is converting spindle heights into on/off commands should i be using the spindle mode ? "

32=1 is the laser mode in 1,0c

I have found a solution,

I ran same gcode file that gave me the errors but this time i ran it in “spindle Mode” in pic sender 1.0c
Vcarve uses the retract , which i have set at 0.254mm to turn the laser off,
in laser mode this retract is disabled ,


That is not true. In Spindle Mode, the Safe Z setting is only for when a job is canceled so the Z axis will retract to a set position above Z zero. This is so the bit does not plow through the material when traveling back to the X&Y axis zeros. It has nothing to do with the Z retract positions in your gcode file.

I suspect your issue was, you are not zeroing the X,Y & Z in Spindle Mode before switching to Laser Mode and running your gcode file. Since your gcode file has vector moves, select the Vector Gcode also. When you run Raster Gcode files, deselect it.

1 Like

You kept stating in the other thread you zeroed Z, so I could only believe that to be true. :wink:

I do learn from other’s mistakes, so I decided to pass that info on here. :laughing:

This exact same thing tripped me up too. Took me awhile to figure out the problem. I only had time for a few tests before I had to pack things up for awhile. Dang move’s had me out of commission for awhile, still trying to get power to the machine as the builder only put one 15A plug in the whole basement thats already full.

What you are looking for can be found here.

1 Like

Picengrave2, where does one enable/disable this vector/raster mode ?

Take a look at this screen shot from version 2.7.4

check the Vector Gcode box

screen shot


I am perfectly happy with my j tech. Jays customer service is outstanding. They are US based, Texas. And I have no interest in cutting with it. For engraving the j tech is great. Unless you are doing 3d laser engravings 6 watts is overkill. The 2.8 is plenty for me.

1 Like