Inventables Community Forum

JTech Laster Set-Up

Hello Everyone,

I installed the JTech laser upgrade earlier today. I opened the Picsender software as recommended. Every since then my Easel software which has worked perfect for the past 6 months no longer works. I cannot operate the X, Y, or Z axis and my machine is no longer detected. When I try to reconfigure my machine it now gets stuck in the “writing configuration” mode. Any way around this?

Thanks

Robert,

I tried that. I even tried the Nintendo method (turning the whole computer on and off again). For some reason it seems like Easel is no longer receiving a signal.

It looks like that was the issue, the Easel software works again.

I would still like to be able to use Easel, partially because my wife knows how to use it and has been helping me with custom orders. That and I still am still learning how to use the PicSender software. Currently when I am able to get the software to connect to the Com port but I am not able to jog the machine manually. Still have to work out those kinks.

If you are using grbl 1.1f or my 1.0c then this post might help you understand how PicSender works with these two laser enabled versions of grbl.

1 Like

Thanks for the reference info.

I was able to get it to job. I didn’t realize that you had to be in spindle mode to operate the Z-axis.

What program do people typically use to generate their G-code based off of an image? Can you do it right in PicSender somehow?

Thanks!

There are many free programs that you can use, other forum members can point you to them.

For paid software, check out PEP6 from the PicSender folks. You can download a trial version from their website.

1 Like