Inventables Community Forum

Jtech Parameter Help

Hey guys,

I recently purchased a Jtech 2.8W laser for my X-Carve. With it I purchased PicEngrave Pro 6 and PicSender. I am working on the initial set-up.

The problem that I am facing is that the PWM functionality of the laser does not seem to be working. I seem to get a constant power output from the laser at all times, engraving me a solid black box. I posted my GRBL settings and PEP6 settings below. I am guessing the problem is within those parameters. Any input?

Thanks!

So you were exactly right that I had int on CW mode. I switched it to Input Control mode. Unfortunately when on IC mode I do not get any power output from the laser.

The Gcode I am testing with seems to be generating correctly (the test logo goes from light to dark, and the S value goes from 10 to 255 respectively). For some reason the laser does not seem to be receiving the input.

Thanks for the quick response.

To be honest, I’m not sure how to check that.

Is there a certain version that works best when integrating the Jtech laser into the X-carve machine? If so, how do I go about updating it? Sorry if this is a dumb question, GRBL is new to me.

From his grbl settings he’s running version 1.1f.

1.1f has some oddities when it comes to lasers.

If you don’t need feed rate or spindle overrides, you can use this version which will be better for you.

You can load it in with this program. (Xloader).

1 Like

Alright so I installed the new version of GRBL (1.0C) by Larry M. It seems I am still having the same issue. No input to the laser when my G-code is running. I did go through and check my GRBL settings to make sure that $30 =255, $31=0, and $32=1.

I also notice now that if I switch to CW mode that no longer turns the laser on. Not sure if that is a sign that the controller and laser are at least talking now?

No. That means you have a hardware issue.

If you remove power from the laser controller you have to press the “reset” button to get the laser to work after you turn it on. It should always work in the CW position regardless of what grbl does.

Check the “safety interlock” jumper to make sure the wiring is ok.

If reset is not the issue then as Jeff says, check your wiring.

1 Like

I was able to look through the wiring and did find an issue. In order to get the laser to work I have to jiggle the wire leading into the laser itself. Seems like a bad connection on the laser that I purchased which is a little disappointing.

With the right amount of jiggling I am able to get the controller to turn the laser on when running my G-code. The only issue that I am having now is that the signal to the laser does not seem to be modulated. My G-code calls out S values ranging from ~10 to 255. It seems like the laser is always defaulting to the full power mode so it is just etching me black boxes right now. Currently the laser is 3 inches from the work piece which I believe was the recommendation in the instructions.

Would it be possible for someone to post their GRBL and PicEngraver settings? I must be missing something…

Get in touch with Jay at Jtech.

With a module that’s failing it’s hard to say where the problem is. Try to get a replacement from Jtech.

1 Like

In the screen shot he provided above, that check box is not checked.

1 Like

Hey guys, thanks for all of the tips. With the M03/M05 box checked it seems to be sending the correct input now! I still have a lot of work ahead of me fine tuning all of the settings but that will be the fun part.

Unfortunately the wiring issue seems to be getting worse so I won’t be able to play around with fine tuning the settings until I get a replacement. I plan to reach out to Jtech tomorrow to see if they’ll replace the bad parts.

2 Likes