Just got mine today

Had a great time assembling it so far. I had to undo and redo a few things because I did a few things backwards. Not sure if I wasn’t paying attention to the directions or they weren’t clear. Some items I caught pretty quickly other items I didn’t. A few screws were swapped leaving me wondering where the screws I needed were :slight_smile:

I have most everything done, I just started the wiring, but will hold off because I ended up buying the router from Amazon and it’ll be here this weekend. I also didn’t have the waste board. I meant to pick it up before the packages came, but I didn’t so that will also be a weekend task.

Here’s hoping the rest will go together well and when the controller comes it’ll all work perfectly (hahaha!).


Enjoy. It’s a fantastic machine and company.

1 Like

I have about 6 hours into the build so far. Everything is done except for the fact I didn’t have a wasteboard since the shipping came as a surprise and I hadn’t started to make it. By the time I had time my kiddos were asleep and power tools are not allowed to be used :slight_smile: I need to make a table for it (I’m likely going to just make a raised platform on a recently perished table saw.

It would have taken a bit less time except I had a number of things that weren’t clear (IMO) in the instructions so some things weren’t done just right (things on the wrong side, etc), plus I used the wrong screws in one place and was scratching my head trying to find them a bit later. I think they do a great job labelling/packing them, but I’d like to see the instructions fixed up. I’ll try to put together some areas where I felt it was either lacking or I had to study the page carefully to make sure I had the left/right correctly made. Or maybe it is the fact that I was doing all my assembly late at night after a long day of work or working around my house without enough coffee. :wink:

Sadly the x-controller doesn’t ship until Wednesday, so the backorder tell me. I cannot wait to get it up and running. Hopefully it works just perfectly.

x-controller showed up, assembled it without too much trouble, sadly I think the holes for the front panel to screw it appears to be untapped, so I couldn’t attach that.

Couldn’t connect via easel, duh! I didn’t install the Easel Driver :slight_smile: Installed it but the Easel setup still won’t connect.

One strange thing is it sounds like the Z axis is clicking away even though I’m not doing anything.

I tried two computers (one win 8.1 one windows 8), neither would connect to the x-controller via easel.

I tried connecting via the serial port and it prints a message (well 1-2 characters at a time if I press the outter two buttons on the x-controller): “NON GENUINE DEVICE FOUND!”


Not nice that it doesn’t seem to work and I planned to take vacation to get it up and running and get some holiday gifts made next week!

Download Universal Gcode Sender. Let’s see if that will connect.

As far as I can tell the Universal Gcode sender connects, but whenever I try to move the axises it says, “Grbl has not finished booting”

I’m going to try to re install the grbl software later today. Hopefully they just forgot to install it

Please contact our Customer Success team 312-775-7009 or via email. The behavior you are describing sounds like something might be corrupted.

Apparently the FTDI driver was the issue. I installed the version from inventables, but I upgraded to version 2.12.24 from the FTDI website and it appears to now work. Time to calibrate when I have time.


Slowly finding time to use mine. I’ve had some minor issues, the wooden clamps seem to periodically come loose, usually after the carve is 80% done and destroys the piece; oops. Hopefully will get the real clamps soon. I designed up a carve for a dust boot, it worked pretty good, not perfect, but does well. I think my dust collector isn’t designed for the 1 1/4 hose it uses, so it’s strained trying to collect the dust through it; I mounting the hose at the front with the full 4" hose and that collects a bunch of the dust too.

My X axis wiring was a bit lose and would periodically skip; found this out when it basically just died. A bit of debug and I realized one of the wires was just a bit lose. tightened it up and back in business, until I accidentally carved through one of the wooden clamps. Oops. I started my 0 at the 0 of the piece of wood and forgot about the clamps and carved right though it.

I’m wondering what I need to do differently to try to cut through aluminium? What type of bits should I use? I have dewalt 611, will that work? I’m thinking of starting with just cutting some shapes out of AL flashing, then moving to something different. A friend mentors for First Robotics, and he’d be happy if I could carve out some parts for his team.