Latest Easel Update Bug - Can't see workpiece

Hey.
I’ve never had issues with Easel before. It’s always been so easy and functional. I downloaded the latest firmware update today and now Easel will not let see my workpieces.

I switched over to another computer without the update. I could see my workpiece perfectly. But when I tried to print, the bit consistently cut above the surface. I ensured the bit was installed correctly, re-zeroed the bit with my z-probe, ensured no warps in my aluminum with nice and tight calming, etc.

I then downloaded the update onto the second computer and now I can’t see my Easel workpiece on neither Safari nor Chrome.

Is anyone else having issues like this since the update?

I had similar. only on some projects. What worked for me is with the workpiece you can’t see open hit command a then command c open a new project then command v to paste and you should see everything.

1 Like

There was an update to Firmware? when did that happen? What’s the version number?

D’oh! Didn’t even think to try copy paste. That worked out, thanks!

This new version is EaselDriver - 0.3.5 . It must have been released some time in the past four days.

Hey @MichelleHuddleston,

I haven’t been able to reproduce the issue on my computer (with my own projects). What OS are you using (specific build/version numbers are helpful), and can you private message (or post here) a project where this occurs?

Thanks,
Eric

Hey @EricDobroveanu,

I’m using a 2014 MacBook Pro running macOS Sierra Version 10.12.3 and a 2012 MacBook Pro running OS X El Capitan Version 10.11.6.

I had this glitch on 2 files: 1 of which I may have deleted??? and 1 of which I can’t even open now linked below:
http://easel.inventables.com/projects/C8O3ESMUAkzlmKtfJj6F1A

Finally got it to open after some finagling, but I still can’t see my workpiece.
http://easel.inventables.com/Heidi+TK2

I can’t seem to get http://easel.inventables.com/projects/C8O3ESMUAkzlmKtfJj6F1A open, looks like the project is corrupted in some way. I’ve created a bug report in our issue tracker. Just to clarify the issue in Easel; you are unable to see your workpieces or the canvas, but are able to set cut settings, add more objects, etc, correct?

It takes a lucky try before being able to open that project. And what you said for the issue is exactly right.

Here’s a screenshot showing the lack of canvas. I tried scrolling around and clicking home but could never find it.