Letter spacing (kerning) and random "fat" letters

All of the belts and pulleys are secure and adjusted correctly, but it seems just about every project I do, even text have problems. I’ve attached two examples. Both were created outside of easel as pictures, converted to svg then brought into easel. One had a border around it and you can see what happened. I’ve put a small picture of the design inside of each photo. If belts and pulleys are how they need to be…why is this happening?

In the bottom photo, most of the letters worked. That tells me (although I’m not expert) that it’s a bug in Easel. I have no clue. On the top photo, ignore the fuzzy edges. That was a bad choice of bit I made. As you can see in the little picture, it just had a simple border, but in the cutting it was all over the place :confused:

If you want to give me you feeds and DOC and some other info I set this up in Aspire for you and send it back your way. If you send it through UGS or Chilipeppr it might help you narrow down the issue… You can shot me a message here if you are interested. If it turns out right (can be scaled down and run on scrap) then it will let you know if it is easel or not.


Easel does have some trouble with text, But the “U” and “O” and the “g” really look like a belt slipped or it missed some steps.

That’s what I thought too, but checked them all thoroughly. May have just been a hiccup lol. Just seemed strange for nearly all the letters to work and then that.

1 Like

Thanks for the response by the way

X-axis is losing steps. Either v-wheels are too tight, the belt does not have a clip on it or is not tight enough or you need to turn up the pot on that axis. Or one of the wires is loose. If you check those things thoroughly, your problem will be solved. Kerning may still be off because of Easel but that is not the only problem here.

I LOVE the sign. Gonna make one for the kids!

I think X steppers set screw is loose. Did you check.?

1 Like

What spindle do you have? I’ve heard others say that the included 300W spindle is very noisy electrically and can cause spurious stepper motor problems. Since the errors all seem to be with the X Axis, and the spindle power and X wiring all run alongside each other, I wonder if you are experiencing the same? My only thought is to pull the spindle power out of the bundle and see if distance helps out.
If you did use shielded wire for the stepper wiring, you could connect the shield to ground only at the power supply end. That should help reduce the susceptibility to EMI.

One way to test for this is to turn in the XC but don’t run a program.
It should just sit there.
Then turn on the spindle. See if the motors move or jitter at all.

Run a simple carve program without a bit (air cut)
Once with the spindle off.
Once with the spindle on.
See if there is any extra movement.

Hi, I had a similar problem. It seems that if you are designing your project outside Easel then saving it as an ordinary svg does not always work.
I designed projects on Inkscape and found you have to save them as an
“optimised s.v.g.” this seems to work .

1 Like

Nevermind, I found it “6th from the bottom” option, but do I uncheck or check anything other than the default way shown below?

Thanks to every one of your for your help by the way. The culprit was that both set screws hat come completely out of the x carriage pulley. I’m now replacing them and using loctite on all of them.

Got it in one.