Inventables Community Forum

Lightburn and missing M4/M5 Codes

Hello all just got my XCarve fitted up with a Optlaser and while the XCarve is moving great, and the laser is cutting as it should, it does not turn off the laser between cuts. For example two 10mm squares set to cut with full power 12 passes each pass .2mm deep. They cut just fine, but when the laser is done with the first cut, it lifts (as expected) and then fast moves to the next cut. Issue is that the laser is still focused and on, moving across the material, resulting in a scorched line.

Shouldn’t the laser turn off before transiting? I realize this is a spindle control, but I dont think it would be hard to issue a M5 while lifting the Z axis and turning it back on with M4 when lowering it.

I cant find any help in the documentation for lightburn, and i’m loath to join facebook to ask :slight_smile:

My only other option that I can think of is to start with the laser de-focused and move with an offset for each cut, but this seems like a hack.

Anyone else encountered this?

Thanks

Which version of grbl are you using?

Response from the nice folks at Lightburn

4 / M5 commands shouldn’t be necessary between cuts because G0 is a non-cutting move. Is your system in laser mode? (Type $32=1 in the console, or $$ to check current settings)

That was the issue. :face_with_head_bandage:

This is only true for grbl 1.1f/g.

1 Like