Lights & motors powering off randomly, won't power back on

Hi everyone,

I’m having some issues with my Carvey. It started a few days ago when I was cutting some linoleum to make a stamp, and about 25 minutes into the cut the lights went off and the spindle stopped. Easel stayed connected and I could hear the hum of the electronics still powered up, but even toggling the power wouldn’t bring the machine back to life. In this state, I can still connect with Easel so I know the electronics are on and working.

I left it for a few minutes, powered it on again after reseating the power cable, and the lights came back on for a minute and then shut off. I left the machine off and unplugged overnight then took the back off to make sure all the connectors were snug (they were).

I turned it on again last night and managed to home the machine, but it was late so I didn’t start a cut. This morning, I turned it on, started to home and before the X and Y axis started moving it shut off on me again.

Easel Driver Version: 0.3.11
Firmware Version: gCarvin 2.0.0

The state shows as alarm but I’m fairly certain that’s only because it’s not homed (unless I can get a code from the alarm state?)

I’m using a recent 13" MacBook Pro with USB and a USB-A to C adapter. I was thinking it could have to do with the USB-C adapter but it doesn’t necessarily make sense because it was working for a solid hour a few days ago, and Easel recognizes the machine still.

Any tips or things to look for would be greatly appreciated!


Could be a power supply failure? When it shut off, what voltage to you read of the PSU?

If the Carvey has a “door open” switch, make sure it is working properly and not vibrating open when you carve.

Thanks for the suggestions, I haven’t had a chance to try a longer cut yet but I did manage to get through a 6 minute cut with no issues using a different USB-C to A adapter. I’ll try a longer cut before the end of the weekend and report back if anything happened, and check the voltage from the PSU too!

Hmm, same thing happening. I tried a different outlet and no luck.

@HaldorLonningdal, how would I go about safely checking the voltage coming from the PSU?


Got it, wasn’t sure if there was anything else I should be using. :stuck_out_tongue:

I finally got a chance to measure, and it read 63.5V across the wires circled in the photo


Any ideas would be greatly appreciated!

Tried a UPS and still running into the same issue. Some extra information: as the motors are going to Home the X and Y axis the wattage peaks at 18, and when everything turns off it goes down to 8 and stays there.

Do you have access to a different 24V PSU? A laptop power cable for instance?
63VDC out of the PSU is too high for sure.

Just happen to have mine apart for other repairs and the PSU is supposed to be a 48V at 8.3 A.


Thank you both for the help! I tried turning the +V ADJ switch but it only dropped to ~54, I didn’t try a cut with that as I’ll try to get a replacement.

I did contact support last night before you both replied, and I’ll update the thread once I get this resolved or get a replacement.

Thanks again!

Edit: I should add, mine is also 48V 8.3A.

I also have the same PSU, I can vary voltage between 39-53V or so.

Interesting! Maybe I’ll try to cut with the now lower voltage and see if that works before ordering a new power supply.

Discussed with Support (they were great) and ordered a new power supply, hopefully that will do the trick.