Limit switch conundrum

I need some help here. Just built my old style 1000mm X Carve and made a mistake whilst soldering limit switch pins. Z and Y axis worked fine but X would did not stop!! Turned out I ruined the G Shield so ordered a new on. Soldered this one correctly, checked continuity and everything is good to go. Go into easel to set up machine and run homing sequence and all that happens it the Z axis moves down about 1/8 inch then stops and nothing else moves. Go into Universal G Code sender…same thing Read somewhere that it may be interference from stepper motors but it worked with old G Shield!
Help please?

But why did the y and z axis work on the old g shield but not on the new one? Nothing has changed but the g shield. I have got some 3 core shielded cable and am going to change it over the weekend and see how it acts then. Other than that everything is working great, done my first carve using easel and worked as expected. Going to try a carve using universal gcode sender next…fingers crossed