Limit switch

Hello, I have a problem with the limit switches. They do not play their function! I checked the assembly and everything is correct.
I’m at the configuration stage with Easel. When I try to execute the homing sequence, it does not stop after pressing the switch (the motor goes up Z, but continues to do so after pressing the switch) .
What should I do ?

Double check you’re wiring, preferably with a voltmeter if you have one.

I had this same problem. Took it all apart and checked all the wiring and connections with an altimeter. Everything was good. Put it back together and it worked. So the engineer equivalent of turn it off and turn it back on again. Just try rebuilding it and see if that does anything.

can you post a picture of the switch and the carriage at the point were it meets the switch

Check connections at switch AND at the controller. You may have accidentally connected some of the wires in the terminal block (which plugs into the controller) improperly.

Thank you for your answers. I solved my problem! It was a problem with the stop screw. At sight, everything seemed fine. But he had to move 1 mm for the switch to release well.