Inventables Community Forum

Limit switches ignored when using the 'jog' function?

I have the 750mm 2017 X-Carve and don’t use it often. I brushed off the dust yesterday and thought I would check the calibration. I used the Easel function where you can plug an increment value in (default I think is 1mm or so). Moving 450mm to the right I measured the distance as 100% on. Moved back to zero, and then up to the top Y axis, across the x, and then down the Y again. At this point, the limit switches seem to be ignored and the machine jumped around and wanted to tear itself apart.

It then did the same returning to zero. Retrying the same process, if I put a value off 449 in when returning to the original position it would avoid the problem as it wasn’t hitting the limit switch.

Is it normal for the limit switches to be ignored in this mode?

Annoyingly, because of all this, I put it out of calibration in the process.

Yes, but you can change the settings to have the machine go into an alarm state when a switch is pressed. The setting is to enable “Hard Limits”.

Most likely just the motor skipping steps. An X-CARVE can’t tear itself apart. Worst thing that could happen is a broken switch if you repeatedly smash it.

1 Like

Great, thanks for replying.

The Xcarve does not have limit switches.

They are homing switches.

You can add switches on each side to create true limit switches but you’re much better off enabling soft limits and setting your X Y and Z max travel values correctly.

2 Likes

A crucial distinction that I didn’t notice!

Looks like my soft limits are wrong. It would be nice if the stepper motors detected a abnormal load a bit faster as it sounds and looks awful when this happens! I had to reach for the panic button on the X Controller.

Thanks

Steppers by definition have no feedback, that’s one reason why missed steps are so detrimental to positioning. You’d need to add an encoder and update to a control system that can do closed loop (positioning based on feedback).

2 Likes

Do you have soft limits enabled?
It’s the $20 value (0 = disabled, 1 = enabled) in your grbl settings.
More info here.

1 Like

@NeilFerreri1 how do I check to see if mine are enabled AND how do I enable them? Thanks Steve

Open Easel, go to Machine Inspector.
In the Console window type $$ and press Enter
The window underneath will now display a list of your current GRBL parameters.
$1-$134

Adding to what Haldor said, to change a setting just type it into the console.
If you want soft limits enabled just type $20 = 1 and press enter.

Yep, Soft limits were turned off. I’ve turned that on now.

Obviously, the default is off. What are the potential draw backs of it being on? I assume you maybe get a little bit of the potential milling area cut off or something?

The benefit is that any commanded movement beyond the limit will prompt an alarm state.
The pit fall is if you have lost steps prior, all bets are off. But the Xcarve is flexible and not strong enough (power wise) to cause damage to itself.

1 Like

I’ve been having this issue as well! I smashed two Z-homing switches already and thankfully I foresaw this so I have a third.

By alarm state that means that on triggering any of the homing switches the machine will automatically stop and abort all motion, correct? Will this also work mid-carve or only during the homing and jogging modes?

They only work in the homing process. If it hits one during a carve it will not do anything.

2 Likes