Limit Switches when manually moving the machine from easel

Is it normal for the machine to ignore the limit switches when your using the arrows in Easel to control your spindle. I just crushed my limit switch AFTER homing the machine and seeing the homing process work perfectly. If this is, then I suggest it be changed please?

I think it might be a GRBL setting for hard limits. I managed to do something similar and crush my Z-axis limit switch (moving by 10mm steps on the X/Y is no problem, do that on the Z and you run out of room quickly!)

However, when I’ve tried to enable hard limits in GRBL it basically acts as if the switches are always tripped. I didn’t have time to look into it this weekend, but it’s next on my list to figure out, so I’ll be sure to share my findings.

I haven’t tried the hard limits yet, but the docs say it is supposed to work with normally open switches, and you can use homing and hard limits at the same time. I was looking into putting a capacitor across the switch terminals to eliminate noise that might be read as a switch press, the might be your issue. I also found there was too much interference on my Y limit switch when I ran the wires in the chain with the stepper wires. I had to run another cable outside the chain just for the Y limit so it would work. This didn’t affect the X and Z however.

I would suggest ordering extra switches so you have them on hand. I have already killed two. I ordered some extra from Inventables after I killed the first switch, but their shipping was so backed up filling everyone’s X Carve order, I ended up ordering some from Amazon as well. Now, having gone through two, I have three extra switches left.

If you are looking for a quick replacement, these work fine.

1 Like

I think my issue with my hard limit experiment was that I hadn’t fully disconnected the crushed switch, and it was registering as closed. Once I pulled that off, the hard limits behaved as expected (more or less).

I ran some test gcode without a bit in the spindle, and with the spindle turned off, and it ran fine, and stopped when I manually tripped a switch. However, you’re right about the noise, once I tried it again with the spindle on, it would trip a hard limit within 30 seconds or so.

I’m going to see if I can find some shielded cable I can use for the switches, hopefully that will clear up some of the noise and prevent some false positives.

Ok so back to the topic of this thread, Are the limit switches supposed to work while controling the machine with the arrows in easel?

I haven’t finished other projects to build mine yet or even explore the parts much, but.I’ve been watching these threads for when I do (I got the 1m kit with limit switches). Would twisting the limit switch pairs and looping them thru a ferrite bead help for noise isolation you think?

Short answer: no, they only work while homing. Another person mentioned it, but the difference is between “hard” and “soft” limits. Hard limits would reset your machine any time the switch is tripped (including jogging the machine), but the switches are very sensitive to noise so hard limits are disabled by default.

Is there a way to programaticly set Easel to remember the homing position and not let you jog past it from the software side of things? Just something built into the jog button logic?

1 Like

Hey Paul Thanks very much. Just knowing and also knowing my switches and set up is working properly helps. I just need to be more careful! Good thing I bought a 10-pack of switches off amazon last week anticipating this might happen! On a side bar, since these switches are fragile and tend to break, perhaps all three locations should be threaded holes instead of just the one on the z carriage. The way it’s made now if x or y breaks theres really no way to get to the tiny nut behind and between things. (X & Y).

1 Like

That might actually be a good feature to suggest to the GRBL team. I was playing around with limits last night, and I found the settings to enable and set soft limits, but right now they only let you configure a max. It seems like it wouldn’t take much for them to also allow you to set a min, which would prevent you from hitting your limit switches. I’ll look into that tonight and see what I can turn up.

@Peter & Sketch. I just got a response from Bart Dring as well and they will be doing a post helping with this soon. :smile:

1 Like

Cool, I just played around with the soft limit ability of grbl, and it will in fact protect you from going below zero once you’re homed. If you have a way to access your grbl settings, you’ll want to set variable $20 to 1 to enable soft limits, and then make sure that you have reasonable max values in variables $130-$132 for x, y, and z.

I tested both trying to go past the max and home values, and in both cases it prevented the gcode/jogging from letting the machine go past the limits.

5 Likes

When I attempt to home the xcarve through easel on ‘machine setup’, it begins with the Z axis. Instead of moving up to contact the limit switch, the Z axis moves down into the wasteboard. FWIW, it functions normally up and down during carving. Is there a difference and how would I correct this?

Grbl has a setting for homing direction in the $$ menu. I think it is $23.

@BartDring any progress on this?

I am sorry, but I have not had a chance to work on this yet. It will be a while before I can do it.

You can use the Easel setup walkthrough to change axis direction for homing.

I’m looking into Easel setting soft limits by default, but I’m worried about causing more problems than it solves. I’ll let you know.

Should I be worried about turning on my machine the first time and busting all the switches? There’s quite a few horror stories of smashed switches on the forum. This doesn’t seem as documented as other parts of the machine. Also as a side bar, I’m stuck at fitting all 5 wires in to ground (spindle, fan, limits)—can i wire them all to a piece of zip wire and put that in?

The Z-Axis limit switch is really the only one that’s typically in danger. And I know I didn’t break mine when I was homing, it was when I was jogging the machine around and didn’t notice that I was still in 10x mode when I started jogging on the Z.

You could start your homing sequence, use a pencil or something to tap the Z switch, and if the axis doesn’t stop right away, you should have time to turn off the machine before anything bad happens. Also I think you could attach the Z switch with a single loose-ish screw, then use a pencil to hold it in place for your first attempt so that if it doesn’t stop, it’ll just pivot the switch.

As far as wiring the ground wires, it’s much easier if you do like you suggest and attach them to a common ground wire, then run that to the shield. I ended up just picking up another terminal block, and I use that for my common ground.