Inventables Community Forum

Limit Switches, Z Probe, and Z Axis Depth are all not working

So I’ve go the 700 mm x-carve up and running but I’m having several issues, I thought i would list them all since they might be connected.

Limit Switches:
I initially set the homing sequence and the switches worked. I tried to reset the machine (due to the later issues) and they no longer do. Now the motors will just run them into the walls until I hit stop. Also every time I’ve done the z-axis homing sequence it would never run to the top. It would go up a good ways and then stop. I would have to restart the whole sequence over to get it to hit the top switch and initially it was working.

Z-Probe:
The set up works, I set the thickness of the puck in the advanced settings. I place it on top of the material and then it raises it slightly and never goes back down towards the material to start carving. It just carves the air. Its like it thinks the material is the material+the puck thickness.

Z axis depth:
I’ve tried to cut out several things but it never goes down the entire depth. I’ve even tried to change the thickness of the material just to see if it would over shoot but each time it only goes down about the same depth.

Not sure if any of these are connected…love to know your thoughts!

I would check all of your wiring.

I had all these same problems when I originally set mine up. I had to go through the machine set up several times to get it to work right and then had to switch some of the wires around. For some reason my control box did not like the drivers they had me install on my computer. My Z-probe caused one of my bits to break while on the first set up. Drove it right through the board I was using to test it.

I would for starters run setup once again and disable homing switches and Z-probe.

Then sort your Z-issue first and get confirmation that everything with the machine is okay and calibrated.
Changing material thickness have no impact on travel, just how deep you can set your design to carve.

I could easily place a 1/4" material to cut, yet tell Easel it is 2" thick. As long as the object/design isnt set to go deeper than 1/4" all will be good.

When you went through the set up do you remember what was wrong?

Got it, will give it a shot tonight. I think I’ve crushed my limit switches so I have some replacements on the way.

In terms of z everything seems to work fine, I can toggle it up and down. But even if I have 1/4 in material, then try to cheat the program by saying it’s 2 inche’s AND making the cut depth 2" it’s only going down the same amount as when I say that it’s 1/4 in.

I never really figured out what it was. I have had to go through the machine setup several times though. It keeps wanting to change the size of my machine on its own and my z probe doesn’t always want to read a true home. Seems to have worked it’s self out for now. The only problem I have now is that I don’t have a planer so I have to set my thickness a little less than what it really is to make sure it starts cutting at the right height. Especially with the V-Carve bits.

Hey Phil . Here is an example. The material is actually 1/4 but even when I set it to 1/2 in with a 1/2 in cut it only goes partially through the 1/4 in material.

If you issue a jog command = 1/2" up on Z, what is the actual travel (measured) ?

I think i’m doing a bad job explaining this.

In real life I have a 1/4 in material. When I do a 1/4 in cut in easel it doesn’t cut all the way through, actually it’s only about half way.

So to get it to cut deeper I set easel to do a 1/2 in cut which I have to change the thickness to 1/2 in to allow it me to. This cut is the same depth at the previous 1/4 in cut.

I get that 1/4 in is the same regardless of thickness. I’m changing the thickness so it would hopefully cut deeper that my actual material.

Is there a way to calibrate it? In easel the only calibration I saw was the jog it just to make sure it would function in different directions but I might have been missing the spot to put in actual units of travel for the stepper motors.

super new to this, is that something I do inside the advanced set up?

yes

Sounds to me like you’re Z axis is bottoming out. You’ve gone as far as physically possible based on the below quote:

I have the same problem cnc 3018 pro, just cut the air :(. did you find any solution?

That sounds like a incorrectly set work zero issue (Incorrect workflow employed)
Or that the machine for some reason isnt able to move properly (stalling stepper motors)

How do you set your work zero?
Describe your steps in detail.