Limits not responding

have had an all of a sudden problem when trying to use the machine today
limits are unresponsive… tried homing and it tried to drive thru the limits.
went to machine inspector checked each limit switch for contact… all function. (green light on contact)
this is just not on one axis, it’s on all…
machine carves as intended, just will not home

That is odd because the trigger sequence is as follows:

  • Feed towards Z only trigger once then pull off and Seek for the 2nd time.
  • If Z succeeded, homing proceed now will to do the same for X&Y .

So the controller had to successfully detect Z-limit in order to proceed with X&Y.
So when you home ($H) the machine want to move past Z, X and Y homing switch all together?

Well, After it failed to home on z axis(and just ground until sequence timed out), I just tried playing with the jog while holding limit switches… strangely enough, when I went back to the machine to fiddle later in the day, it homed just fine… I didn’t change anything… weird…