Line 42 Invalid G-code syntax

Hey everyone,

Its been awhile hope all is well. Anyway, I fired of my x-carve today. I built a project in Aspire and saved in layers as normal. Loaded up my clearing layer and ran it no problem. Went to do my next layer and Easel did not like it.

Invalid G-code

Line 42: G2 X8.1489 Y0.9637 I0.2341 J0.6271
The file contains invalid G-code syntax.

You must use one of our official post-processors in order to import external gcode.

Any suggestions? I did everything as usual. The clearing layer went just fine.

Thanks for any assistance.

Which post processor did you use, it looks like Easel does not like the arcs in the g-code.

I used Vectic Aspire’s option for the X-Carve in inches

You need to use the one that is for Easel, I believe there is a download link in Easel.

Oh ok. I thought they would be one in the same. I’ll check on that now.

In easel click Help then downloads and choose the post-processor for Vectric.

Open Aspire, click File then Open Application Data Folder there is a folder called PostP and My_PostP (and others).

If you want to see all post-processors available in Aspire place the postprocessor from inventables in PostP.

If you only want to see the easel Post Processor in Aspire put the file in My_PostP

Thank you very much. This was it. I very much appreciate the assistance. I hope you have a great day sir.

1 Like

Anytime :slight_smile: