Lock motors not working?

So I was having a go at a 2-stage carve in Easel with a 1/8 straight bit, the finishing with a 60 degree v-bit.

At the time to change bit, I hit carve for the finishing pass, and then hit Lock Motors before I started changing the bit. As I was undoing the collet, the spindle moved a little on both x and y. I thought the Lock Motors button was supposed to hold things steady while I changed the bit? I recovered it enough for this carve, but have I misunderstood what that is for?

Also, there was no way of knowing if the motors were locked or unlocked at any time. I couldn’t see anything obvious to tell me if they were locked or not.

Am i missing something?

thanks in advance.

I see the same thing. It seems to make no difference if you click on either lock or unlock. I don’t understand why you would want to unlock the motors?
Mine have always been locked with or without 2 stage carve.

Check GRBL value $1=255
Xcontroller may have a dip switch that en-/disable motor lock?

Ok, relevant for the Xcontroller is to have the dip switch setting OFF for “reduce current when idle” and GRBL $1=255 to have them fully energised all the time?

You are not wrong. Torque reduction is a hardware setting with the DIP switch in the X-controller.

Yes, pretty much :slight_smile:
Since I dont have an Xcontroller I wasnt sure how things work, but remember I read something related to that issue.

Anybody has pic or two of these dip switch settings to be able to lock the motors please.

1 Like

So I pretty much solved my problem without changing any of the settings.

I had a little bit of time, so I decided to do a tune up following the video guide on the inventables website. One of the things they suggested was tightening up the eccentric bolts that hold the wheels on the underside of each axis support. In the video, they needed to be tight enough so that you could just move the wheels by hand.

Well mine were almost spinning freely, which had meant that any reasonable pressure to the gantry and it would slip.

I tightened mine up considerably, and now I can apply a good deal of pressure to the gantry without any slippage. It will still move a little if I press hard, because I didn’t want to over tighten them and seize the mechanism.

While I was there I tightened up the belts as well, which were a little looser than ideal.

Well worth trying this first before changing any other settings.

1 happy woodworker here.


Hi Robert,

I didn’t change the switches at all. But I think my movement was happening with the motors locked. I think it was basically slippage by the wheels.



In which case, I’ve no idea!! :slight_smile:

I didnt’ touch the switches at all…


I believe that tightening the belts will make it harder to slip as well.

The ultimate solution is disabling the torque reduction. Just wait till you’re doing a long multi-bit carve and your gantry slips during a bit change and you lose your zero position…it takes 5-10 minutes to flip the 3 switches.

1 Like

I just turned the torque reduction switches off. But now there is a constant audible hissing coming from the X and Y motors. I turned the switches back on to verify the difference. Negligible hissing in the on position, but greatly increased in the off position. I this a potential problem?

I have read a few older posts that seem to be talking about this sound. I have tried to attach a video, without success.

You can hear the sound start during the homing sequence. It then continues after the motors have stopped. Some of the older posts say that this is the ardrino trying to power the motors constantly, and that this can lead to the motors heating up.

Is that why the torque reduction was added? Can this cause premature wear on the motors?

If its not a problem, I’ll leave it. But if there is potential early failure issues, then I will switch the DIP’s back. For me, the carriage accidentally moving, isn’t a huge issue, more of an occasional annoyance.

Wish I could get the video clip up.( edit figured out the YouTube requirement)


Post to YouTube and link the YouTube.

I don’t really notice a hum to my motors.

What’s your $1 GRBL setting? It could be a cycling of lock/unlock you hear.

Thanks @JustinBusby I finally figured out that I had to do that route. Now I guess I will need to learn some YouTube. :exploding_head:

The $1 is set to 255.

With the dip switches set to on, I can hear a similar sound coming from the steppers while they are moving. But not when stopped.

My concern is that this is the motors constantly working, it could wear out them out.

The “hiss” is not a sign of a problem, just the coils resonating to the switching frequency of the driver.
Some positions make it appear and a minor jog may make it disappear/reappear.

1 Like

Also if you have power on to the stepper, it is technically working (coils energized). How else would they get the holding torque?

I doubt you’d have an issue.


Thanks @JustinBusby, @PhilJohnson. The knowledge from experience gives me some confidence that I’m not killing it. I’ll leave the switches off.

1 Like

I have never had an issue with 2stage, just raise the z and change the bit, nothing would move at all.
It seems since I did the last update this has changed. My machine is about 5 years old.
Pressing lock does nothing…
This is really causing some grief while doing rough and detailed, all three axes are moving freely just like I shut the power off to the motors.