Locking "home" position for bit changes

so I’ve read a few people are having a problem keeping their home position when changing bits and I think I may have come up with an easy solution, at least it works for me.

I installed some post assembly t-slot nuts with 5mm bolts on the makerslide on both the x and y axis on both sides of the motor assemblies. After the X-Carve homes, I slide these over until they are contacting the bracket assemblies and tighten the bolts down (not too tight, you don’t want to bend the aluminum extrusions). Now the assemblies are locked in place. Once I change the bit, I set my z, raise the bit, and loosen all the bolts and slide the t-slot nuts all the way to the ends of the makerslide so they don’t act as an obstruction (I leave the bolts in.).

Seems to be working perfect so far! Such an easy solution, I’m not sure why no one has mentioned or thought of this before!

If this isn’t making sense, I’ll post some pics later if you need… I’m just in the middle of a long carve right now! Keddy

1 Like

Another option is to use the grbl setting $1=255
That keeps the motors powered while it is turned on and essentially locks the motors.

1 Like

No wonder I couldn’t get this to work.

I was trying to do $255 = 1


I’ve read some posts where some of the guys were saying the grbl setting was holding strong enough. In my case, my setting keeps reverting back to unlocked everytime I turn off my machine for some reason, so I came up with this mechanical means to lock everything in place.

1 Like

If it works and you are happy with it, then it is all good :slight_smile:

I’ve found that whenever I change an Easel setting, I need to hit the refresh button in the Machine Inspector screen, and then reload Easel. Once I did both things, it kept my $1 setting.

I don’t think I’ve done the reload, I’ll try that… Thanks!