Locking Steppers

I tried to lock my steppers in UGS with $1=255 for a bit change. Well that didn’t go well the spindle moved when changing bit, in fact I could move all axis’s. So in reading I entered M6 into command line and motors locked.

  1. Is $1=255 suppose to lock steppers or should I use M6

  2. How do I unlock steppers if I what to release them from M6 or $1=255

Not enough information here to speculate, but if you have $1=255 the stepper motors should stay engaged all the time that power is applied and the Arduino/gShield have power either through the USB cable or an external power supply.

Are you using the Arduino/gShield electronics or something else?

Not a good idea to release the spindle if you don’t want to lose position.

Yes the Ardunio/Gshield. Yes I know I would lose position when I would release but I just would like to know if the lock status could be released. That was the problem when it did not lock I lost my 0,0 and works fine with the M6 command

So, are you saying that the $1=255 does keep the motors engaged and you would just like a method to disengage them?

I just checked the grbl documentation and it doesn’t list M6 as one of the supported commands. I’ll have to look at that later.

No $1=255 does nothing motors stay free but M6 locks them I saw a post for Chilipepr for the M6 command and tried that, and it locked motors.

If your power supply is turned on and $1=255 is set, the motors stay powered and essentially locked. If you have nema 23 motors, with that setting, you will have a hard time moving any axis while changing bits.

M6 is simply a tool change in your gcode, grbl ignores M6, chilipeppr may do something with it.

If setting the variable $1=255 did not keep the motors engaged, then verify that the setting stayed…Issue a $$ command.

Power was on. Do have the nema 23’s. I will have to play to see what going on but M6 works on my grbl

One last thing, I have no idea how much experience you have with routers, but when you tighten the bit, it just needs to be tight, not cranked with all of your might :slight_smile:

Did you reload the settings in Machine Inspector, and then reload Easel? I’ve found that changes won’t apply until you do that. Sometimes it takes a couple tries.


I took some time to look into this and I only found four cases where the $1 paramter is sampled:

  1. during the Arduino power up cycle
  2. during a soft reset (UGCS)
  3. during a homing sequence
    [Edit] 4) hardware reset the Arduino

There may be others , but I haven’t been able to find any.

So, if you change $1 back and forth you will not get any effect unless you do one of the above four things.

Your mileage may vary.

Just checked and I don’t know what software you are using, but grbl returns an error if you issue an M6 command.

Your investigation into the $1 parameters may be the answer

So if I set $1 to 200,000,000 I will get 200 seconds, correct? With it set to 255 it is .000025 seconds and I don’t care how fast you are a tool cannot be changed it that short a time.

255 keeps the motors locked the entire time the gshield has power.

$1 - Step idle delay, msec

Every time your steppers complete a motion and come to a stop, Grbl will delay disabling the steppers by this value. OR, you can always keep your axes enabled (powered so as to hold position) by setting this value to the maximum 255 milliseconds. Again, just to repeat, you can keep all axes always enabled by setting $1=255.

I do not know why but after installing the 23s and powering up the axis moved pretty free. However, after a few on/off cycles they now lock just fine.
I did not change any setting or parameters so I can only assume it decided to do what it was supposed to do.
Thanks for the reply.

1 Like

Go to Machine Inspector…type $1=255 into the command line and hit ENTER. Then go to CARVE and jog z axis up or down once and your motors will lock…I just tested this on Xcarve 750 with xcontroller.

Just noted you’re using UGCS… same thing…bottom line is $1=255 doesn’t do anything until you jog one of the motors.

FYI $1=0 releases

hello do you have to type $1=0 after you change the tool, or will the motors unlock when you press carve again?

As I recall they will do their thing without entering anything.