Loosing Steps on X Axis - Stuttering in X- Direction but smooth on X+

Try to move the X axis by hand with the 24 volt power supply turned off. Move it slowly and see if you feel any difference in the resistance when moving left or right. This might help determine if the problem is mechanical or electrical.

Hi @LarryM

I tried that and it seems like i only get resistance in form of a grinding noise when i push it too fast. I get the same noise on the Y axises.

I also saw though that in general it seems like the Vwheels are loosing some of their substance. I attached pictures. The grey ‘dust specs’ come from the VWheels it seems. It can be found on the X and Y rails, and also in the ‘groove’ of the wheel itself.

The Eccentric nuts dont seem to be too tight though. I also checked the belts and they are definetely not slipping, so i can rule that out. The rails are also square to each other, and the Y axis rails are paralell to each other as well.

Another thing i found out is that the left Y axis carriage is slightly closer to the bracket that attached to the wasteboard rail than the right side of the Y axis. If i manually move them to bring them back to be both equaly far away from the bracket, they are off again after a full move of the Y axis. Then they stay always the same though, like the distance does not change after that. Again, the Y axises are parallel to each other (i measured the distance between them on multiple spots) and they are also square to the X axis and the table.


The V wheel in the picture looks like it is damaged. Are those pits in the surface of the V wheel, or bits of material stuck to the wheel?

I don’t think it should be that way.

The wheels are smooth and the rail is too but the wheels seem to leave the grey ‘debris’ on the rail, it seems to rub off or so

I guess the next thing I would try is to clean the V wheels and rails to remove all of the built up material then see what happens when you move the X and Y axis by hand.

See if any of the V wheels are not rolling, but dragging when you move the X and Y axis.


The debris is metal though it seems and not wood. I have only been cutting wood so far. I usually vacuum the machine after each run, I didn’t vacuum though when I took the photos but usually it’s clean.


All wheels are moving and the grey metal debris is definetely coming from the wheels when I move the carriage but I’m not sure why since all wheels are turning when I move the carriage.

I’ve noticed the same gray crud buildup as well, and have been cutting primarily MDF. I’ve got a stiff plastic bristle brush that I use to clean the wheels and can remove it from the rails with a paper towel, but it always comes back.

Ran some more checks today.

I set a new x y z 0 position, and marked the spot. Then i jogged the X and Y axis around for a minute or two, little steps (0.1) inches, long ones at 1 inch per step, and then hit the return to 0, and it always came back to the same spot.

I suspect it only shows up when im cutting, or after a long time cutting. Not sure how i can test that, i am getting frustrated with this. :frowning:

The thing that throws me off is that while its cutting from the left to the right its all straight and fine, no skipped steps. But once the carriage goes from the top on the Y axis back to the bottom the Y to start the next pass, its instantly off a full 5 mm.

Any advise is welcome.


Which stepper motors do you have?

Are you comfortable working with a Volt meter in tight spots?

How do you have the wire for the router run? If it’s inside the drag chain, try taking it out and running it on the outside. It’s a stab in the dark, but maybe there’s interference from such high current draw similar to what happened with the regular 24V spindles. Also, if you used shielded wires for the steppers maybe you should try to ground them.

1 Like

@LarryM I have the NEMA23 steppers, all my parts came with a fully spec’ed out 1000mm XCarve kit. Im not even comfortable running a Volt meter in large areas :wink:

@RobertA_Rieke I have the wire run as per instructions, in the drag chain. I am not sure if the Dewalt would cause the issues, i just did some more tests (i attached videos to each section):

-I did some air cuts, running the dewalt spindle on regular speed (and another one with spindle off), and positioning it on 0 0 0. Then i marked 0 again and ran the job that i ran the past days. I had it run for a few minutes, then cancelled the job and had it return to 0. It always made it back to the exact same spot.
Video1 Video2 Video3 Video 4 (The squeeking from time to time is when the Z axis moves up and down)

-I took a slow motion video from it moving from the farthest Y back to 0, and couldn’t see any steps being skipped:

-I took a video here that shows you my belt setup, and the sound it makes when i move the carriage without powering the motors:

-I also tuned the Pots according to the video that got posted here 2 days ago.

-If somebody wants to try the carving, let me know and I upload it. It’s made for a 1/8th ball mill, and the dewalt. You need to set 0 0 0 on top of stock, bottom left corner. Wood needs to be 16x28x1 inch.

It will make multiple passes, and when the second pass starts, you can see the issue already because it will be off.


I have looked at video1 over and over and over and over again.

Here is what I have noticed. It appears that the sound that is not “smooth” only occurs when the router is moved up or down on the Z axis and that sound seems normal to me. Can you set up a file to move the X axis without moving the Z and see if you still get the noise?

Also, I don’t know if it’s because I am viewing the video over the internet or not, but it seems that your X axis V wheels are not rolling all of the time. I see some spots where it doesn’t roll, or the video is dropping frames. I tried to download the video to play in from my disk, but I wasn’t able to do that.

The sound that it makes when you are moving the Y axis by hand is normal. When you move the X axis by hand I do hear something that is a little off.

Do you know how to dump out the grbl parameters (using the $$ command)?

@LarryM Thanks for checking on the videos! Yeah the squeeky sound is only when the Z axis moves up and down, so that is normal.

I think Dropbox is mangling the video a little so its stuttering a little bit and dropping frames. I sat yesterday next to the machine for a long time watching the vwheels to see if they are all turning, and they are all turning at all times. I was hoping too it would be as easy as tightening a nut or so :slight_smile:

And i have not dumped the parameters yet, but i can do that when i get back home if i know how to do that. Is it just issuing the $$ command via the command option in UGCS?

I watched the video of you moving the machine by hand with the power off. That is a normal sound. Stepper motors by there very design make noise when you rotate them by hand. With the belting hooked up you can rotate them much faster and that is the sound you will get from them. All OK there.

edit. Just watched video 3 Keep a close eye on the top left V wheel as the carrage moves back and forth. You will see that wheel stop turning and slide on the rail for a short distance. You may want to check your V wheels again looks like there may be some miss adjustment there.

@DavidSohlstrom Hi David,

you are right, i checked the original video too and it seems like that top left wheel gets stuck for a second before it keeps moving. I will check later if i can reproduce it. The more interesting questions will be what causes it to get stuck there…


Hi Larry,

here is the output:

**** Connected to COM6 @ 115200 baud ****

Grbl 0.9j [’$’ for help]
[’$H’|’$X’ to unlock]

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

I also tried the job again, and its off still.

This time, even more than usual and its off already after about 4 minutes minutes:

0 before the carving:

After return to 0 after the carving:

It now seems to carve it sideways but still parallel:

Thanks, Oliver.

Sometimes the $1 parameter is not set right, which can cause positioning errors. Your parameters look good.

I’m still trying to figure out what I’m hearing when you move the X axis by hand. The Y axis sounds right, but the X axis doesn’t.

Can you get me a video with more of the X axis movement by hand and do it rail to rail. The current video only has a short amount of movement along X and I just can’t isolate what I’m hearing. The speed that you were moving it was fine.

How do you return to zero after the carve?

I read through your post again to see if I could get a better idea of what’s happening. You said that you had the current limit potentiometer at about 70 percent. That may be too high.

Since you said no to the voltmeter, try setting your X axis potentiometer like this one.