Loosing Steps on X Axis - Stuttering in X- Direction but smooth on X+

Hi Larry!

I tried the original files from their website, just changing the bits to my 1/8 inch ballmill and then recalculating all paths, and i got the same issue one it starts making the circle.

I give it another try though today with UGCS 1.0.8 or so to see.

But even if this works, im not sure why the first one that i was trying like 6 times didnt work. Its a larger file but i would still think it doesnt cause issues.

I have used the NOMAD with files of the same size and it worked fine. It was using their proprietary carbide motion software though.

Yes I had heard that also. The GRBL developers need to cure that problem because the way they are doing things is hard on your machine.

I also think that if Oliver wants to run these complex parts that it would be to his advantage to move to stepper drivers and control software that can handle complex parts.

Dave

File size problem is a UGS problem. Not surprised that the NOMAD doesn’t have this problem.

I wonder if i can convert my X-Carve to a Shapeoko 3 or so somehow so that i can use their software cause i did not have any issues with that software or the machine carving 12h jobs that just do the raster carving.

Maybe i contact them to find out.

Both machines use the grbl G code interpreter, so if you are having an issue with grbl it should appear on both machines.

It would be interesting if someone else could use your file and see if they have the same result. That would at least give another data point and suggest whether or not the problem is in the front end or the machine. It’s unlikely that two machines would fail the same way.

Most of the things that would cause an offset error due to hardware would be a random offset. The fact that you are seeing a 5mm error consistently suggests that it’s not a machine problem.

I’m not set up for carving right now and I have the smaller machine anyway, else I could do it.

At this point I’m not sure what to suggest. I guess if it were my machine I would design some simple square and circle cuts to see if the problem occurs there. If you got good results with those then move up to something more complicated to see where it breaks.

I will try today to run a pocket cut from Easel to see if its software related. I am not sure though if easel cuts the same way as VCarve does, but at least its a test. I will just cut a big square pocket about .25 inch deep and a circle pocket with the same depth after that.

We will see…

Sounds like a good plan. If the Easel cut works right then try the same design/cut with V-carve.

@LarryM

Hi,

so i just finished a 5x5 inch .25 deep pocket square in the same wood as before (same mill etc) and same issue…

I did however loosen the X axis belt a tiny bit, and tightened the pully set screws one more time.

Another square is cutting now so we see if that helps. I can definetely rule a GRBL sender related issue out since Easel does the same thing.

Oliver

That did it!

It now came out straight in Easel!

Next step: Trying my carving that i made in VCarve. Lets see…

Alright!!! When your carve finishes take a mirror and examine the teeth on the X axis belt to see if there is any wear.

I bet that’s it. I was thinking about that a little when I watched your video where you snapped the belts with your finger. But, not having any experience with that issue I didn’t think it was the problem.

Add another learning experience. I really hope the next carve works out. You have struggled with this a long time. Glad you stuck it out.

Now the fun begins.

Nope that wasn’t it. Same issue. Again. its off again. I think I’m pretty much done with this machine.
Really not sure what to do anymore, but so far i wasted about 2000$ on this ‘project’ and it just does not work.

I am wondering though if its because the carriage is chattering / wobbling / stuttering whatever you wanna call it when it moves back on X. X+ is smooth, X- is not. It must have to do with that. Which is weird since it takes the same cut depth and speed and everything going X+ than it does X-.

Could the NEMA stepper be the issue? I would think if the belt is too tight its too tight in both directions. If the screws are loose, it causes it also in both directions (and they are tight i checked again after the job). Checking with EASEL doesn’t really work either because easel doesn’t go left right left right for the pockets but rather does a concentric approach, so its not really the same for testing.

I am really lost on this.

1 Like

Well, that’s too bad I thought you had it.

There are two other things I thought about, but it is rather involved.

Here’s what I would do if it were mine.

Take the router out of the mount. Completely loosen the belt on the X axis to the point that it doesn’t apply any pressure at all on the stepper pulley or idle wheels.

Then see if you have any play whatsoever in the X carriage.

You may have some loose V wheels that are masked by the tension on the X axis belt and the weight of the router.

If that doesn’t locate a problem then I would swapped one of the Y stepper motors for the X stepper motor and see if that makes any difference.

My suggestion is go ahead and squeakily clean your machine, slides and Vwheels first. No particles, no build-ups left.
Then you have to go thru all your Vwheel alignments one more time. Here is the best to understand tightness on wheels.
Try to turn wheel with your finger, must be difficult to turn, but must be turn all if them in same level. If one side is loose, other side is tight, problem begins. To have even alignment, you must take your belt off. Because when you try to push the axis one way or other, stepper generates power back to Gshield, which makes break. Don’t rush it. Do not install belts until you are completely sure they are all same.

1 Like

Hi,

so i cleaned the machines and loosened all the wheels, and the belt, and was able to freely and smoothly move the carriage around.

I then put it all back together and it looks good and moves fine. I also took the old mill bit out and put in a brand new fresh one.

I restarted the long job that always fails from my last 0 0 0 position so that i dont need to waste more wood. Now after the first pass is over in about 1h, will see if it comes back to the correct position or if it is off.

When its running now i don’t see the stuttering anymore on the X- way to the left, but that could be too because the mill has nothing to mill, since it carved it away already in my last try. So the second pass in an hour will show more results.

If it is not offset anymore, then it could be that it was caused by the stuttering before or the milling bit (although i don’t know why it would be cutting fine in one direction and not fine in the other direction).

So far i can already tell that the stuttering is not in the gcode.

If its still off, then it doesn’t have to do with the stuttering. If it is off, the stuttering is most likely the cause. I will then for another try turn the wood around and let it carve on the fresh back side so i can see if it stutters again.

I really hope i can figure this out soon, its getting super frustrating.

1 Like

If it is off, I wonder if there’s a way for a stepper to be mechanically or electrically weak in one direction. Not necessarily fail, but maybe have a wee bit more resistance to turn one direction, like a sort of ratchet action.

If this test shows the stuttering, I would get in touch with Inventables and ask them for a replacement stepper. Don’t give up yet, this seems to be a unique problem that may be easily fixed with a new part. It’s frustrating, but the playtime is well worth it once you get the problem licked.

Hi,

so the first past (which was just aircutting) went well. When it came back for the second pass, it was aligned.
Its running the second pass now (cutting wood actually) but i didnt see any stutter either so far, so my hopes are high.

We will know more in one hour.

Oliver

1 Like

:pray: I’ve been watching…

Sure hope this one works.

Thanks everyone! I am running pass 3 now and all is good still. One Pass left :smile:

1 Like

Update please.