Loseing steps in Y axis

On my 3d printer missed or extra steps in one axis only and on intermittent layers are caused by either incorrect stepper driver voltage or the stepper driver getting hot. The machine (a Solidoodle v2, pretty old these days) had test points and pots on the mainboard for adjusting the voltage, and I had to add a cooling fan blowing across the drivers as well. Not sure if the Xcarve has any potential similar issues or calibration advice??

1 Like

The steppers getting too hot is one possible problem- do you have a fan on the electronics? That, and maybe try turning down the current?

Otherwise, it may be that you have a slightly loose wire on that axis, which would result in intermittent inconsistent behavior. Check through the wiring and make sure it’s all solid. If you used the terminal blocks, sometimes it looks like the wires are firmly in there but you’ve accidentally pinched the insulation instead and the copper is barely making contact.

1 Like

:confounded: Good call on the overheat problem, been there and done that - on 3d printers. I do have a fan on the board and Even with that the is significant heat on the y axis ramps chip. I am running it at 24v, so just for fun, I’m going to try a 12v supply on the board and see if that helps.

There are times when pulling this board and replacing it with a Mega and Ramps boards.

which board are you using?

@LarryKruzan Just a heads up a 12v supply will most likely exasperate any overheating problems you might be experiencing.

I can’t find the link to the exact board, but this http://www.ebay.com/itm/161651684271?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT is identical to the same one I’m using. It is basically a GRBL board that I’ve used in a couple other applications.

It does provide for driving the two y steppers with individual drive chips - I haven’t done that yet, but it should be a way to keep current draw down and drop temps.

Hi @larrykruzan I’m sorry I’ve never used that board before. Do you have access to a Arduino and G Shield to test? If it is doing the same behavior as that board then you probably have a mechanical problem. If it does not lose steps with the Arduino and Gshield then you probably have a problem with your board.

http://www.shapeoko.com/wiki/index.php/Dual_Motor

Review the serial vs parallel section. The default is parallel, I used to see this same issue sporadically, after moving to a serial wiring wiring, I have not had the issue return.

Thanks Zach. I’m afraid I don’t own a gshield board, but I do have plenty of Arduino boards and a couple raspberries too. I’ll have to order a gsield to test one.

I’ve also got to try splitting the y steppers up and trying it that way before I buy a lot of other boards.

A couple of issues on my end. Received the 1000mm last week and had it up and running by Sunday. Did a couple of test runs using basic 3/4 inch pine and everything was spot on. I then switched to 1/8 Birch for a real project and nothing but issues.

Issue 1: Near full depth plunge on first pass despite setting a .02 and .01 depth per pass (Easel). No idea what else to do. Tried generating in VCarve 8.0 and importing the SVG and still no joy.
Issue 2: Off set, off set, off set on second passes initially and now it off sets by the time it completes the first pass.
Issue 3: Stuttering/Sputtering from left Y-carriage. Right carriage sounds smooth. X and Z sound very smooth.

Forum surfing–
Issue 1: Still no clue after reading.
Issues 2 & 3: Tightened belts, checked the x-maker slide was 90 degrees out and even on both the left and right y-maker slide, and played with the eccentric nuts. Still no clue on how tight is too tight for belts and spin/no spin on the eccentric nuts.

Seriously demoralized and defeated at this point.

1 Like

Might try a little more current from the Y channel of the gshield by turning the pot a bit…might explain one motor on Y a little weak. But that does sound more mechanical,

Check square by measuring diagonals between Y rails? Make sure X carriage starts out same distance back from both Y rail fronts at beginning of job? (It’s easy to manually drag it a little bit off-square by hand with motors off.) Also watch the pulleys…are the toothed wheels turning or is the chattering sound from a belt slipping over it on one side? A lot of problems are from the little setscrews not gripping the motor shafts enough and letting the pulleys slip. Also verify they’re in line with the smooth idlers and the belt isn’t riding up say on one side of the idlers but the other side of the pulley.

As far as belt tightness and vwheels I don’t know what’s “right” either aside from not binding (too hard on motors) but not loose (too imprecise and likely to backlash). Try a little line with a silver sharpie on each vwheel so you can watch it in action on a non-cutting run and make sure they’re always rotating with movement. If they’re not, they’re probably a tad too loose. If they are but you can’t put your finger on one and roll it and move the carriage without really trying hard (motors off of course) they might be too tight. My belts ‘thrum’ but don’t “twang”…tight enough to sort of vibrate if plucked but not so tight they make what I’d call a musical note.

For the depth any chance you have the wrong unit in depth or perhaps defined the wrong thread (ACME vs. normal) running setup?

Richard,

Many thanks for the response and reaffirming recommendations on this and other threads.

In short, I checked square/level, the belts and pulleys are installed correctly, adjusted one v-wheel on the left Y carriage and increased the power to the y channel of the shield. Made several test runs on on 3/4 pine and all appears to be working except for depth. Transitioned to 1/8 Birch and all but depth appears to be working.

So as of right now there is not stuttering/chattering from the left side, cuts start/finish as expected with no off set, and the machine returns to home (of the material) as was another issue experienced yesterday. Its just the depth at this point. Confirmed I’m using the ACME Delrin kit and ensured the hardware/software reflects the configuration and in inches. Just baffling at this point.

Easel dug too deep with easel created shapes. Imported SVG from VCARVe and experienced the same. Tried the VCarve to UGS route and I have to home the bit on the waste board just to get it to cut into the material. Trying to reduce the variables at this point and focus on getting Easel and X-Carve to work correctly, then take on VCarve, UGS or Chilipeppr.

Again, thanks.

UPDATED: Cut a few project items out of 1/8 Birch plywood with the same thickness of birch underneath to preserve the waste board. Lesson learned–clamping down the outer edges will compress and throw off the cut depth to the outside and potentially bow the material upwards (without too much issue) towards the center. Investigating double sided tape but both sides of the project cutouts will be visible. Somewhat worried about gumming up the wood and creating extra work for what could be a couple thousand small pieces in a short amount of time.

Issue 1: Deep cut on first path still plaguing the operation. I’ve had to reduce the cut depth to between 1/16 and 1/32 so as not to completely dig in and rip through the 1/8 work material in one pass.

I shouldn’t have to use Kentucky windage and can’t create tabs without putting this depth (z axis) issue to bed.

You might try to increase the voltage on the Y-Axis on the G-Shield. This drives 2 motors and if pushed to hard will skip steps. :wink:

Bill

I’ve been having those (depth of cut and skipping steps) issues also. Just so we all know, what is the correct GRBL setting if you’re using the ACME option? I did run setup with Easel but now use UGS. I try to cut into the board only 0.065 (1/16") but it cuts double that. I did a test of four circles, each pas is shifted towards the back of the machine and the depth is not as I setup.

Great machine though, huge kudos to Zach and the team for bringing something accessible and versatile to market. Us tinkerers are just never satisfied!

You and me both. I have had nothing but this issue since the beginning and the help has been spotty at best. What is a well tuned belt? Who knows! How much current is too much or too little? Who knows! Can the Gshield really handle the Nema 23s I ordered? Who knows (but probably not)! This thing has been a colossal waste of time and money. Probably just broke all the community guidelines with my negativity too, I mean its about the Journey right? Wrong. It is about pissing away $1400 on a machine that only works for five minutes at a time if at all.

1 Like

That’s really unfortunate that you are having so many issues. Although I feel that there are pretty good answers to all the issues you stated on the forums. @RobertA_Rieke has created a couple videos that really help with the set up of the machine. Don’t be afraid to ask for help, there are a lot of people in the community that are willing to help! Good Luck!

2 Likes

These videos are awesome. Here’s the link to his channel :

The last three videos :

36 - X-Carve Stepper Calibration
35 - Adjusting X-Carve Potentiometers
34 - Setting X-Carve Belt Tension

Thank you @RobertA_Rieke and very nice work.

Here’s my unit.

3 Likes

I’m losing steps in the y-axis also, about 10mm and only losing steps on the last pass
I’m cutting on .58" birch plywood.
Y-axis lost steps on last pass when settings were 60ipm feedrate, .08" depth per pass (12min to complete), and feedrate 45ipm, .07" depth per pass (9min to complete).

Actually when running the first time on recommended setting, there was no slippage but this same piece took 42min to complete… and that’s just way to slow to accept as defacto for wood haha
I"ll try cutting again at default settings to see if will slip or not slip on y-axis this time

I have the same happened yesterday when I adjust the current in the controler and filped the fan in wronge way , and start working after awhile, I saw many loosing steps, I stop the work and check for any hardware problem but nothing all things is good.
thanks Richard for this notes,today I will fix the problem by filp the fan and see what happen.

The X Axis running correctly but the Y having problems makes me think that driving two motors from one channel is not a good thing to do. I had been using the g-Shield on a mill and lathe before getting into X-Carve and those systems only have one motor on each axis. I’ve never had a problem of losing steps with them. I bought a 1000mm X-Carve framework and didn’t actually put it together as it came from the factory. Instead I designed and milled two new gantry end plates with some other mods to drive the Y axis with a single stepper motor (left side only). As a result of the mod, my clearance is 60mm higher and the two sides of the gantry stay square because of the shaft that mechanically locks the two sides together. So I can push one side of the gantry and the other follows instead of the mooshy gooshy behavior of the stock X-Carve. One might think that the Y axis might need more power than the X because it carries more but I think that my Y axis actually moves more easily and smoothly than the X. Having the same motors (and the same number of motors) on each of the three axes greatly simplifies tuning of the drive current. I wonder why Inventables didn’t design their system like mine in the first place.